summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2025-01-04 14:53:34 -0500
committerMatt Turner <mattst88@gentoo.org>2025-01-04 15:03:35 -0500
commitf3caa4db8e65ccf767a5b0b893ca3a28c1e39bea (patch)
tree5d59189fd520e6021b413116da2bd16eab1a92f5 /media-libs/mesa/mesa-9999.ebuild
parentdev-python/aiohttp: Remove old (diff)
downloadgentoo-f3caa4db8e65ccf767a5b0b893ca3a28c1e39bea.tar.gz
gentoo-f3caa4db8e65ccf767a5b0b893ca3a28c1e39bea.tar.bz2
gentoo-f3caa4db8e65ccf767a5b0b893ca3a28c1e39bea.zip
media-libs/mesa: Workaround multilib build failure
Closes: https://bugs.gentoo.org/939803 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 11cf7cc6900c..7846e415a4f5 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -471,6 +471,15 @@ multilib_src_configure() {
fi
}
+multilib_src_compile() {
+ if [[ ${ABI} == x86 ]]; then
+ # Bug 939803
+ BINDGEN_EXTRA_CLANG_ARGS="-m32" meson_src_compile
+ else
+ meson_src_compile
+ fi
+}
+
multilib_src_test() {
meson_src_test -t 100
}