summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-23 08:58:40 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-23 10:27:22 +0100
commitf55f23c96ea54f9411b69003f658e5a8fff753ee (patch)
tree918c0c53501c0d76ee1517be41328eb44759d50a /media-libs/oneVPL
parentdev-libs/ncnn: add 20230223 (diff)
downloadgentoo-f55f23c96ea54f9411b69003f658e5a8fff753ee.tar.gz
gentoo-f55f23c96ea54f9411b69003f658e5a8fff753ee.tar.bz2
gentoo-f55f23c96ea54f9411b69003f658e5a8fff753ee.zip
media-libs/oneVPL: add 2023.1.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-libs/oneVPL')
-rw-r--r--media-libs/oneVPL/Manifest1
-rw-r--r--media-libs/oneVPL/oneVPL-2023.1.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/media-libs/oneVPL/Manifest b/media-libs/oneVPL/Manifest
index 8706a1f7dd1d..836fa8b41796 100644
--- a/media-libs/oneVPL/Manifest
+++ b/media-libs/oneVPL/Manifest
@@ -1,2 +1,3 @@
DIST oneVPL-2022.2.5.tar.gz 6517210 BLAKE2B 1da487e9a4fbaa171f14213d0828c7dbed91d1f92d9641f10d9ef8fc895b4d51b33f80485b16e41e2cb15cd8d771f5c5f84370268cb2c347dc8e19d90d91a759 SHA512 7d100a347a109720f37d86c6dd86c216a75e77b9f032f5c066835fb5a3c7c7312bca81ffd3a30836c59d20e10863567788a247b4daa57721b3ba011c4e0cd34d
DIST oneVPL-2023.1.1.tar.gz 6346209 BLAKE2B 043064fb5781ec0f23cbc2eedb5371bdd1718ae862bd9ae492529ab501b034d2a8d5c4814c5ce219bd15894bc6139dd3b2bef7c7ac4b8a5e9cd37502f022faf8 SHA512 a3df5ebafd748a887cb581525d07af930d3e3b4930d5d2adc5bc2629e385d1802b3315b8f02a3c66956a3dbb46b008e680687ebf125b344a34e86b9cc0910faa
+DIST oneVPL-2023.1.2.tar.gz 6317287 BLAKE2B 3333d32eb5370ac32136337dae122238ddc9c8ccf2a3634f27d79ccb375a62e79054af8e1ad20677c2e11d522bd6978deeeb2ba04e1876cc1dd130f22ff2e9d2 SHA512 674e352375efcb8cce88965bfed33642c1bbfb707e6d26522b48ac670d7f1467b07b66f881b2d83a7f919f707f1782ecda709d5775545c5a87bb0058daa005c5
diff --git a/media-libs/oneVPL/oneVPL-2023.1.2.ebuild b/media-libs/oneVPL/oneVPL-2023.1.2.ebuild
new file mode 100644
index 000000000000..223184c18698
--- /dev/null
+++ b/media-libs/oneVPL/oneVPL-2023.1.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature
+
+DESCRIPTION="oneAPI Video Processing Library, dispatcher, tools, and examples"
+HOMEPAGE="https://github.com/oneapi-src/oneVPL"
+SRC_URI="https://github.com/oneapi-src/oneVPL/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="dri drm examples experimental +tools test vaapi wayland X"
+RESTRICT="!test? ( test )"
+# Most of these flags only have an effect on the tools
+REQUIRED_USE="
+ dri? ( X drm )
+ drm? ( tools )
+ X? ( tools vaapi )
+ wayland? ( tools drm )
+ vaapi? ( tools )
+"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ x11-libs/libpciaccess
+ vaapi? ( media-libs/libva[X?,wayland?,drm(+)?] )
+ drm? ( x11-libs/libdrm )
+ wayland? (
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_DISPATCHER=ON
+ # Headers, cmake and pkgconfig files
+ -DBUILD_DEV=ON
+ -DBUILD_EXAMPLES="$(usex examples)"
+ -DINSTALL_EXAMPLE_CODE="$(usex examples)"
+ -DBUILD_PREVIEW="$(usex experimental)"
+ -DBUILD_DISPATCHER_ONEVPL_EXPERIMENTAL="$(usex experimental)"
+ # Fails to build with experimental tools off if tools on
+ -DBUILD_TOOLS_ONEVPL_EXPERIMENTAL="$(usex tools)"
+ -DBUILD_TESTS="$(usex test)"
+ -DBUILD_TOOLS="$(usex tools)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ -DENABLE_X11="$(usex X)"
+ -DENABLE_DRI3="$(usex dri)"
+ -DENABLE_VA="$(usex vaapi)"
+ -DENABLE_DRM="$(usex drm)"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ # Remove these license files
+ rm -r "${ED}/usr/share/vpl/licensing" || die
+}
+
+pkg_postinst() {
+ optfeature_header "This package provides only the dispatcher, to use it install one or more implementations"
+ optfeature "CPUs" media-libs/oneVPL-cpu
+ optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
+ optfeature "Intel GPUs older then Intel Xe" media-libs/intel-mediasdk
+}