summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-03-22 05:47:06 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-03-22 05:47:06 +0000
commitc19dae2bc1676744ef1e3edd2d74f0c431c91097 (patch)
tree1b628e44b94a695f05b0c9e87932f3a6c8bcb1be /media-libs/x264/x264-0.0.20220222.ebuild
parent2023-03-22 05:32:03 UTC (diff)
parentsys-devel/crossdev: Stabilize 20230209 ppc, #902645 (diff)
downloadgentoo-c19dae2bc1676744ef1e3edd2d74f0c431c91097.tar.gz
gentoo-c19dae2bc1676744ef1e3edd2d74f0c431c91097.tar.bz2
gentoo-c19dae2bc1676744ef1e3edd2d74f0c431c91097.zip
Merge updates from master
Diffstat (limited to 'media-libs/x264/x264-0.0.20220222.ebuild')
-rw-r--r--media-libs/x264/x264-0.0.20220222.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-libs/x264/x264-0.0.20220222.ebuild b/media-libs/x264/x264-0.0.20220222.ebuild
index c8bcf46dda7b..954a0d3550ea 100644
--- a/media-libs/x264/x264-0.0.20220222.ebuild
+++ b/media-libs/x264/x264-0.0.20220222.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib-minimal toolchain-funcs
+inherit multilib-minimal toolchain-funcs flag-o-matic
DESCRIPTION="A free library for encoding X264/AVC streams"
HOMEPAGE="https://www.videolan.org/developers/x264.html"
@@ -41,7 +41,13 @@ multilib_src_configure() {
local asm_conf=""
- if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !cpu_flags_ppc_altivec ; }; then
+ if \
+ [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } \
+ || [[ ${ABI} == "x32" ]] \
+ || [[ ${CHOST} == armv5* ]] \
+ || [[ ${ABI} == ppc* ]] && { use !cpu_flags_ppc_altivec ; } \
+ || use mips && { ! test-compile 'c' 'int main(void){__asm__("addvi.b $w0, $w1, 1");return 0;}' ; }
+ then
asm_conf=" --disable-asm"
fi