summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:17 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:17 +0200
commit4872f542d3a6c11f6ce61cddcfb2fccdf850c799 (patch)
tree8811e1ba08ffd26eb3585e25f7203b36ca8f5295 /media-libs
parentmedia-gfx/solvespace: [QA] tc-has-openmp → tc-check-openmp (diff)
downloadgentoo-4872f542d3a6c11f6ce61cddcfb2fccdf850c799.tar.gz
gentoo-4872f542d3a6c11f6ce61cddcfb2fccdf850c799.tar.bz2
gentoo-4872f542d3a6c11f6ce61cddcfb2fccdf850c799.zip
media-libs/libopenshot: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.5-r1.ebuild15
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.6.ebuild15
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.7.ebuild15
3 files changed, 9 insertions, 36 deletions
diff --git a/media-libs/libopenshot/libopenshot-0.2.5-r1.ebuild b/media-libs/libopenshot/libopenshot-0.2.5-r1.ebuild
index 0ce3d1ebb499..d641166cc5e0 100644
--- a/media-libs/libopenshot/libopenshot-0.2.5-r1.ebuild
+++ b/media-libs/libopenshot/libopenshot-0.2.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -43,21 +43,12 @@ PATCHES=(
"${FILESDIR}/${P}-no-hwaccel-testfix.patch"
)
-check_compiler() {
- if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
- eerror "${P} requires a compiler with OpenMP support. Your current"
- eerror "compiler does not support it. If you use gcc, you can"
- eerror "re-emerge it with the 'openmp' use flag enabled."
- die "The current compiler does not support OpenMP"
- fi
-}
-
pkg_pretend() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
pkg_setup() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
use python && python-single-r1_pkg_setup
}
diff --git a/media-libs/libopenshot/libopenshot-0.2.6.ebuild b/media-libs/libopenshot/libopenshot-0.2.6.ebuild
index af6f8eedbf89..a77d75b47edb 100644
--- a/media-libs/libopenshot/libopenshot-0.2.6.ebuild
+++ b/media-libs/libopenshot/libopenshot-0.2.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,21 +38,12 @@ BDEPEND="doc? ( app-doc/doxygen )
dev-libs/unittest++
)"
-check_compiler() {
- if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
- eerror "${P} requires a compiler with OpenMP support. Your current"
- eerror "compiler does not support it. If you use gcc, you can"
- eerror "re-emerge it with the 'openmp' use flag enabled."
- die "The current compiler does not support OpenMP"
- fi
-}
-
pkg_pretend() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
pkg_setup() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
use python && python-single-r1_pkg_setup
}
diff --git a/media-libs/libopenshot/libopenshot-0.2.7.ebuild b/media-libs/libopenshot/libopenshot-0.2.7.ebuild
index 45cad1c947ad..d016f2abc25d 100644
--- a/media-libs/libopenshot/libopenshot-0.2.7.ebuild
+++ b/media-libs/libopenshot/libopenshot-0.2.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,21 +38,12 @@ BDEPEND="doc? ( app-doc/doxygen )
dev-libs/unittest++
)"
-check_compiler() {
- if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
- eerror "${P} requires a compiler with OpenMP support. Your current"
- eerror "compiler does not support it. If you use gcc, you can"
- eerror "re-emerge it with the 'openmp' use flag enabled."
- die "The current compiler does not support OpenMP"
- fi
-}
-
pkg_pretend() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
pkg_setup() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
use python && python-single-r1_pkg_setup
}