summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-04-28 20:14:06 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-28 20:14:24 +0200
commit5dc8e55481861cadd97d8587da2ab32d7e1d9f28 (patch)
tree979b58f38c388f82738dfdcd4beaa4e1a020bedd /media-libs
parentsys-apps/less: Removed old (diff)
downloadgentoo-5dc8e55481861cadd97d8587da2ab32d7e1d9f28.tar.gz
gentoo-5dc8e55481861cadd97d8587da2ab32d7e1d9f28.tar.bz2
gentoo-5dc8e55481861cadd97d8587da2ab32d7e1d9f28.zip
media-libs/libsidplayfp: bump to 2.1.2
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsidplayfp/Manifest1
-rw-r--r--media-libs/libsidplayfp/libsidplayfp-2.1.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/libsidplayfp/Manifest b/media-libs/libsidplayfp/Manifest
index bf3ffff4b7a2..a91006b14e5c 100644
--- a/media-libs/libsidplayfp/Manifest
+++ b/media-libs/libsidplayfp/Manifest
@@ -1 +1,2 @@
DIST libsidplayfp-1.8.8.tar.gz 673522 BLAKE2B 2d31955e08b0b2b9558e033eff5d959acda08cdc5a3c2bb8c0aacb07c4b8c105812b4faa0af07dbc51255c72cfdf4893ce0da4d642dfc0f89ebc6ec96c51db51 SHA512 84fb24dcf6680dd0e2ec9cc39ddaf30707e4beb5136b7b496b1b85bf11580b1080fbb59b6ec3c1dc7b829fa0cd933db89ee3968518f23ef1a35d9253707d6392
+DIST libsidplayfp-2.1.2.tar.gz 788212 BLAKE2B 1959404d8b694e9271276bd3a7d32298747fcfc52fc96da3ebae16e23ed9c1825cda4810bff5ad39a0ca7f173300f6b86791ff589ee78bf05c9e12bc49bccaf5 SHA512 c044cc835666a7616b2c16e8f186877caa42c80c74ae2fd503868f77311ed6bc8df58cbb72e7086477adec1ba314bd4f1410a733642ff18baf1596afa1a9b22b
diff --git a/media-libs/libsidplayfp/libsidplayfp-2.1.2.ebuild b/media-libs/libsidplayfp/libsidplayfp-2.1.2.ebuild
new file mode 100644
index 000000000000..8712fad9752d
--- /dev/null
+++ b/media-libs/libsidplayfp/libsidplayfp-2.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Library for the sidplay2 fork with resid-fp"
+HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="mirror://sourceforge/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/6"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="cpu_flags_x86_mmx static-libs"
+
+src_prepare() {
+ default
+ # fix automagic. warning: modifying .ac triggers maintainer mode.
+ sed -i -e 's:doxygen:dIsAbLe&:' configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_mmx mmx)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}