summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-06-08 15:13:45 +0200
committerSam James <sam@gentoo.org>2025-01-05 20:33:28 +0000
commit7099accf62c2108320b4aaeb9e8f65320f5fe865 (patch)
tree2ce379746da1e9ebcd8a51f693188f24f4b983f7 /media-libs
parentmedia-libs/osl: default to qt6 for USE=gui (diff)
downloadgentoo-7099accf62c2108320b4aaeb9e8f65320f5fe865.tar.gz
gentoo-7099accf62c2108320b4aaeb9e8f65320f5fe865.tar.bz2
gentoo-7099accf62c2108320b4aaeb9e8f65320f5fe865.zip
media-libs/partio: add 1.17.3
Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/partio/Manifest1
-rw-r--r--media-libs/partio/partio-1.17.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/partio/Manifest b/media-libs/partio/Manifest
index 859d45911c02..625bfd47bf9d 100644
--- a/media-libs/partio/Manifest
+++ b/media-libs/partio/Manifest
@@ -1,2 +1,3 @@
DIST partio-1.14.6.tar.gz 336527 BLAKE2B 60c9c6ad9d5a7b58967e7633180d4f8d399bd129cc7b76fc4329b3d191ce0d381df7f977d5ec11ccedbdbcd8afa0fde2f946960f08a242338c2f674b4c94343e SHA512 5479d00b3124e8e06abbc65b1cdc01cdac37b9207c0615029e488baa0835e4ad545be2fb07dda5b4541dd846115059aaca5950ff904bddec6bb1fd72180ebcc0
DIST partio-1.17.1.tar.gz 338461 BLAKE2B 6c08d5b74db34ce114206ab92332e42e827d537d83e65597ba777344e1b9dc69f9b57153f716e87df6955b9898cedcd7e6da353db111463d7c8bd47f648cca6a SHA512 5dbbd988c76a26ac6f3024e29ed12f37f7995daf211e065b9ffaf185c6203be7d9de48bd62b5955d2f5444af72fb3306ea5a0f3501cb0a49a26f157bb09ec6bc
+DIST partio-1.17.3.tar.gz 338044 BLAKE2B 5842c5e1ee728d5e3ea77258293b1cd0a72147ac1229e2156741cfe9a55971e2dd30d2b8e239b0a3cde8e055f564d98cd7c29cf649d33eb9f1891158ba69c1c7 SHA512 b110d29b9d4226c773adf8b98f0bcb78a877d5bf944b09500d81d2810dc2e4cc1386cbe29aa724fc256c00f6df34e171a091b2ddc60aedc9fa2576eb00a3fefa
diff --git a/media-libs/partio/partio-1.17.3.ebuild b/media-libs/partio/partio-1.17.3.ebuild
new file mode 100644
index 000000000000..9ed9d5b09bde
--- /dev/null
+++ b/media-libs/partio/partio-1.17.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake python-single-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wdas/partio.git"
+else
+ SRC_URI="https://github.com/wdas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library for particle IO and manipulation"
+HOMEPAGE="https://partio.us/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/freeglut
+ media-libs/glu
+ sys-libs/zlib
+ virtual/opengl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-lang/swig
+ doc? (
+ app-text/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake_use_find_package doc Doxygen)"
+
+ -DPARTIO_GTEST_ENABLED="$(usex test)" # "Enable GTest for tests"
+ -DPARTIO_ORIGIN_RPATH="no" # "Enable ORIGIN rpath in the installed libraries"
+
+ -DPARTIO_USE_GLVND="yes" # "Use GLVND for OpenGL"
+ -DPARTIO_BUILD_SHARED_LIBS="yes" # "Enabled shared libraries"
+
+ -DWDAS_CXX_STANDARD=17
+ )
+
+ cmake_src_configure
+}