summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-10-07 11:02:20 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-10-07 11:02:20 +0200
commit5374d15a95991c798908cdd24fdbd0d2bbacb4ed (patch)
tree95ff1deb00936085119cbf5de046ac602aef1a8f /media-libs
parentmedia-sound/alsaplayer: added missing build dep in 0.99.82 (diff)
downloadgentoo-5374d15a95991c798908cdd24fdbd0d2bbacb4ed.tar.gz
gentoo-5374d15a95991c798908cdd24fdbd0d2bbacb4ed.tar.bz2
gentoo-5374d15a95991c798908cdd24fdbd0d2bbacb4ed.zip
media-libs/libsidplayfp: bump to 2.10.0
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsidplayfp/Manifest1
-rw-r--r--media-libs/libsidplayfp/libsidplayfp-2.10.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libsidplayfp/Manifest b/media-libs/libsidplayfp/Manifest
index 36e6a0d965e2..08d58b73ea43 100644
--- a/media-libs/libsidplayfp/Manifest
+++ b/media-libs/libsidplayfp/Manifest
@@ -1 +1,2 @@
+DIST libsidplayfp-2.10.0.tar.gz 811416 BLAKE2B 5d81c1c74eccb5b4e176a82e1232eed7a5687bd6dd5c22b0941d414be438db54f0d303bb0c26445404beb94f9d01cf78ec57983e8a11dd265ec6f94947a71b2b SHA512 ebffc99d04e4e5ef309636c08105b42150c5b707bcb6ecd196ee6956f301ae152efdfdd86b14276e31a0936d97cc534caec4e2281249df6ba7571926a1daffeb
DIST libsidplayfp-2.9.0.tar.gz 807772 BLAKE2B 9ec5066a69f912c4183e98c4883875b646c9f6150ab4bd3c8d9a7110a9c75529cdb6f8aeac8d379ecacf2c0ec6181a8ee13ff93bcc53f296b8900b0e6c8d5281 SHA512 3d6b0b6ab5155da3ae4cface17a2fe85deb1dd8ab8076dba60f04e5df78b10dc9b756b408734a1012e254d3d24d8cfcf15b562fdb1f28edd756a5d63719595b0
diff --git a/media-libs/libsidplayfp/libsidplayfp-2.10.0.ebuild b/media-libs/libsidplayfp/libsidplayfp-2.10.0.ebuild
new file mode 100644
index 000000000000..bc7c3460f07e
--- /dev/null
+++ b/media-libs/libsidplayfp/libsidplayfp-2.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for the sidplay2 fork with resid-fp"
+HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="https://downloads.sourceforge.net/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/6"
+KEYWORDS="~amd64 ~hppa ~riscv ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ # fix automagic. warning: modifying .ac triggers maintainer mode.
+ sed -i -e 's:doxygen:dIsAbLe&:' configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}