summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-22 12:52:10 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-22 12:52:10 +0100
commitc1f8600f3e6b88718748f759547a3dfc7e6d4496 (patch)
tree2718403c8d7c32b343a9cafee8b4e1cf65854ca9 /media-plugins/gmpc-jamendo
parentmedia-plugins/gmpc-avahi: Port to EAPI 7 (diff)
downloadgentoo-c1f8600f3e6b88718748f759547a3dfc7e6d4496.tar.gz
gentoo-c1f8600f3e6b88718748f759547a3dfc7e6d4496.tar.bz2
gentoo-c1f8600f3e6b88718748f759547a3dfc7e6d4496.zip
media-plugins/gmpc-jamendo: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-plugins/gmpc-jamendo')
-rw-r--r--media-plugins/gmpc-jamendo/gmpc-jamendo-11.8.16.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/media-plugins/gmpc-jamendo/gmpc-jamendo-11.8.16.ebuild b/media-plugins/gmpc-jamendo/gmpc-jamendo-11.8.16.ebuild
index bf20216ce05a..fc37e3e4d09a 100644
--- a/media-plugins/gmpc-jamendo/gmpc-jamendo-11.8.16.ebuild
+++ b/media-plugins/gmpc-jamendo/gmpc-jamendo-11.8.16.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="Plugin allows you to browse and preview music available on jamendo"
HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_JAMENDO"
@@ -12,14 +12,18 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
-RDEPEND=">=media-sound/gmpc-${PV}
+RDEPEND="
+ >=media-sound/gmpc-${PV}
dev-db/sqlite:3
dev-libs/libxml2:2"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
dev-util/gob
- nls? ( dev-util/intltool
- sys-devel/gettext )"
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
src_configure() {
econf $(use_enable nls)
@@ -27,5 +31,7 @@ src_configure() {
src_install() {
default
- find "${ED}" -name "*.la" -exec rm {} + || die
+
+ # plugins only
+ find "${D}" -name '*.la' -delete || die
}