summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-05-20 20:22:52 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2023-05-21 09:42:37 +0200
commit1c6f6237975331084706c4935bddd56af4349f2a (patch)
tree45713321da66c2967fe08176703417e457346b1a /media-sound/zynaddsubfx
parentprofiles: desktop/plasma: Set IUSE=pipewire,pulseaudio in make.defaults (diff)
downloadgentoo-1c6f6237975331084706c4935bddd56af4349f2a.tar.gz
gentoo-1c6f6237975331084706c4935bddd56af4349f2a.tar.bz2
gentoo-1c6f6237975331084706c4935bddd56af4349f2a.zip
media-sound/zynaddsubfx: backport GCC 13 fixes
Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/31109 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/zynaddsubfx')
-rw-r--r--media-sound/zynaddsubfx/files/zynaddsubfx-3.0.6-stdint.patch46
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-3.0.6-r1.ebuild3
2 files changed, 48 insertions, 1 deletions
diff --git a/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.6-stdint.patch b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.6-stdint.patch
new file mode 100644
index 000000000000..4590183ab0f9
--- /dev/null
+++ b/media-sound/zynaddsubfx/files/zynaddsubfx-3.0.6-stdint.patch
@@ -0,0 +1,46 @@
+Upstream Commit: https://github.com/zynaddsubfx/zynaddsubfx/commit/f384d92486d6b515cb628d0f52008a9e03341d8c
+Upstream Commit: https://github.com/zynaddsubfx/zynaddsubfx/commit/70905c96fe7b9ffde19bc4bc05b0dc53a1ed1707
+
+From f384d92486d6b515cb628d0f52008a9e03341d8c Mon Sep 17 00:00:00 2001
+From: fundamental <mark.d.mccurry@gmail.com>
+Date: Wed, 19 Apr 2023 21:52:01 -0400
+Subject: [PATCH] Bank: Add stdint.h header include
+
+As uint8_t is used, this header should be included.
+---
+ src/Misc/Bank.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/Misc/Bank.h b/src/Misc/Bank.h
+index 5120441a5..3f324dd84 100644
+--- a/src/Misc/Bank.h
++++ b/src/Misc/Bank.h
+@@ -18,6 +18,7 @@
+ #include <vector>
+ #include "../globals.h"
+ #include "Config.h"
++#include <stdint.h>
+
+ //entries in a bank
+ #define BANK_SIZE 160
+
+From 70905c96fe7b9ffde19bc4bc05b0dc53a1ed1707 Mon Sep 17 00:00:00 2001
+From: fundamental <mark.d.mccurry@gmail.com>
+Date: Sat, 22 Apr 2023 10:21:09 -0400
+Subject: [PATCH] MidiIn: Add stdint.h header include
+
+---
+ src/Nio/MidiIn.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/Nio/MidiIn.h b/src/Nio/MidiIn.h
+index ce0bcfec3..c6b30c61d 100644
+--- a/src/Nio/MidiIn.h
++++ b/src/Nio/MidiIn.h
+@@ -17,6 +17,7 @@
+ #define MIDI_IN_H
+
+ #include "Engine.h"
++#include <stdint.h>//uint8_t
+
+ namespace zyn {
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-3.0.6-r1.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-3.0.6-r1.ebuild
index 91346729c831..ed506ba3f20e 100644
--- a/media-sound/zynaddsubfx/zynaddsubfx-3.0.6-r1.ebuild
+++ b/media-sound/zynaddsubfx/zynaddsubfx-3.0.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -45,6 +45,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-docs.patch
+ "${FILESDIR}"/${P}-stdint.patch
)
DOCS=( AUTHORS.txt NEWS.txt README.adoc )