summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-08-04 08:00:53 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-08-04 08:00:53 +0200
commitcc3d6712332c6a25b6758aa846d17e2c5a1a6a9c (patch)
treef906f0a00afd7e35f37bf771c876ab267da61450 /media-sound
parentdev-java/swt: drop 4.27 (diff)
downloadgentoo-cc3d6712332c6a25b6758aa846d17e2c5a1a6a9c.tar.gz
gentoo-cc3d6712332c6a25b6758aa846d17e2c5a1a6a9c.tar.bz2
gentoo-cc3d6712332c6a25b6758aa846d17e2c5a1a6a9c.zip
media-sound/mpg123: dropped obsolete 1.31.2
Closes: https://bugs.gentoo.org/904737 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpg123/Manifest1
-rw-r--r--media-sound/mpg123/mpg123-1.31.2.ebuild110
2 files changed, 0 insertions, 111 deletions
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index 433e8b8b0dd1..196f128cab9c 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,2 +1 @@
-DIST mpg123-1.31.2.tar.bz2 1093881 BLAKE2B a5c2d0a5df6067322979176498592a429c36fa06000b512e944b1f6ceeeae29fa3efeb0e5d604c8f2930aa51ae75e53be4312abaf74e43504fb1643b66b8b682 SHA512 eca285382ee3e780353834addf1336c4a2f8f11256af22f95e11efa243de669761c083c86ddfc6ac8c02a920a3c4ab4ad767efa2739fb052e9719f35ef407bc3
DIST mpg123-1.31.3.tar.bz2 1094474 BLAKE2B 343bca53e067485dba438a177ba65f38d512c4aaac6f413bb1e070f99d6407f9a694899f06fbd3577ef287b4e898b38ac3585f86d18f643cab15f678d3105c11 SHA512 5dd550e06f5d0d432cac1b7e546215e56378b44588c1a98031498473211e08bc4228de45be41f7ba764f7f6c0eb752a6501235bcc3712c9a8d8852ae3c607d98
diff --git a/media-sound/mpg123/mpg123-1.31.2.ebuild b/media-sound/mpg123/mpg123-1.31.2.ebuild
deleted file mode 100644
index 4834ae56d825..000000000000
--- a/media-sound/mpg123/mpg123-1.31.2.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs libtool multilib-minimal
-
-DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
-HOMEPAGE="https://www.mpg123.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
-
-# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
-# Note: build system prefers libsdl2 > libsdl. We could in theory add both
-# but it's tricky when it comes to handling switching between them properly.
-# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
-RDEPEND="
- dev-libs/libltdl:0
- alsa? ( media-libs/alsa-lib )
- jack? ( virtual/jack )
- nas? ( media-libs/nas )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- sdl? ( media-libs/libsdl2 )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
-"
-IDEPEND="app-eselect/eselect-mpg123"
-
-DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
-
-src_prepare() {
- default
- elibtoolize # for Darwin bundles
-}
-
-multilib_src_configure() {
- local _audio=dummy
- local _output=dummy
- local _cpu=generic_fpu
-
- # Build fails without -D_GNU_SOURCE like this:
- # error: ‘struct hostent’ has no member named ‘h_addr’
- append-cflags -D_GNU_SOURCE
-
- append-lfs-flags
-
- if $(multilib_is_native_abi) ; then
- local flag
- for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
- if use ${flag}; then
- _audio+=" ${flag/pulseaudio/pulse}"
- _output=${flag/pulseaudio/pulse}
- fi
- done
- fi
-
- use cpu_flags_ppc_altivec && _cpu=altivec
-
- if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
- use cpu_flags_x86_sse && _cpu=x86-64
- elif use x86 && gcc-specs-pie ; then
- # Don't use any mmx, 3dnow, sse and 3dnowext
- # bug #164504
- _cpu=generic_fpu
- else
- use cpu_flags_x86_mmx && _cpu=mmx
- use cpu_flags_x86_3dnow && _cpu=3dnow
- use cpu_flags_x86_sse && _cpu=x86
- use cpu_flags_x86_3dnowext && _cpu=x86
- fi
-
- local myconf=(
- --with-optimization=0
- --with-audio="${_audio}"
- --with-default-audio=${_output}
- --with-cpu=${_cpu}
- --enable-network
- $(use_enable ipv6)
- --enable-int-quality=$(usex int-quality)
- )
-
- multilib_is_native_abi || myconf+=( --disable-modules )
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-
- if ! $(multilib_is_native_abi) ; then
- sed -i -e 's:src doc:src/libmpg123:' Makefile || die
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
- mv "${ED}"/usr/bin/mpg123{,-mpg123}
- find "${ED}" -type f -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- eselect mpg123 update ifunset
-}
-
-pkg_postrm() {
- eselect mpg123 update ifunset
-}