summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2020-01-23 21:31:52 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2020-01-23 21:33:25 +0100
commit25d7e7d79368b7625221486d1d32f5c515901854 (patch)
treeb578a9a114e9c71d5424b34379523ac361f5e4b8 /media-video/noad/noad-0.8.6-r4.ebuild
parentmedia-video/noad: cleanup old (diff)
downloadgentoo-25d7e7d79368b7625221486d1d32f5c515901854.tar.gz
gentoo-25d7e7d79368b7625221486d1d32f5c515901854.tar.bz2
gentoo-25d7e7d79368b7625221486d1d32f5c515901854.zip
media-video/noad: license, dead homepage, src_uri fixed
sources are not available by upstream anymore Martin Dummer has pickupded the sources and added to git hub this is a community managed project now Closes: https://bugs.gentoo.org/682394 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-video/noad/noad-0.8.6-r4.ebuild')
-rw-r--r--media-video/noad/noad-0.8.6-r4.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/media-video/noad/noad-0.8.6-r4.ebuild b/media-video/noad/noad-0.8.6-r4.ebuild
new file mode 100644
index 000000000000..170684dc966e
--- /dev/null
+++ b/media-video/noad/noad-0.8.6-r4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Mark commercial breaks in VDR recordings"
+HOMEPAGE="https://github.com/madmartin/noad"
+SRC_URI="https://github.com/madmartin/noad/archive/v0.8.6.tar.gz -> ${P}.tar.gz
+ http://vdr.websitec.de/download/${PN}/${P}-ffmpeg3.4.diff.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ffmpeg imagemagick libmpeg2"
+
+RDEPEND="
+ libmpeg2? ( media-libs/libmpeg2:= )
+ ffmpeg? ( virtual/ffmpeg )
+ imagemagick? ( media-gfx/imagemagick )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( ffmpeg libmpeg2 )"
+
+src_prepare() {
+ default
+
+ #compile tested libav-13, ffmepg-3.4
+ eapply "${WORKDIR}/${P}-ffmpeg3.4.diff"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(usex imagemagick '--with-magick') \
+ $(usex ffmpeg '' '--without-ffmpeg') \
+ $(usex libmpeg2 '' '--without-libmpeg2') \
+ --with-tools
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" # see bug #469810
+}
+
+src_install() {
+ dobin noad showindex checkMarks
+ use imagemagick && dobin markpics
+
+ dodoc README INSTALL
+ # example scripts are installed as dokumentation
+ dodoc allnewnoad allnoad allnoadnice clearlogos noadcall.sh noadifnew stat2html statupd
+
+ newconfd "${FILESDIR}"/confd_vdraddon.noad vdraddon.noad
+
+ insinto /usr/share/vdr/record
+ doins "${FILESDIR}"/record-50-noad.sh
+
+ insinto /usr/share/vdr/shutdown
+ doins "${FILESDIR}"/pre-shutdown-15-noad.sh
+
+ insinto /etc/vdr/reccmds
+ doins "${FILESDIR}"/reccmds.noad.conf
+
+ exeinto /usr/share/vdr/bin
+ doexe "${FILESDIR}"/noad-reccmd
+}
+
+pkg_postinst() {
+ elog
+ elog "To integrate noad in VDR you should do this:"
+ elog
+ elog "start and set Parameter in /etc/conf.d/vdraddon.noad"
+ elog
+ elog "Note: You can use here all parameters for noad,"
+ elog "please look in the documentation of noad."
+}