summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-23 10:30:21 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-23 10:34:37 +0200
commit8ed2ae42d9e1a2c3df7ed8f116d7ab470de4358a (patch)
treec20f47ea408ff12fe221d14ca61f5fd9f5caca81 /net-analyzer/netselect/netselect-0.4-r1.ebuild
parentnet-libs/nodejs: Set PYTHON_REQ_USE="threads(+)" (diff)
downloadgentoo-8ed2ae42d9e1a2c3df7ed8f116d7ab470de4358a.tar.gz
gentoo-8ed2ae42d9e1a2c3df7ed8f116d7ab470de4358a.tar.bz2
gentoo-8ed2ae42d9e1a2c3df7ed8f116d7ab470de4358a.zip
net-analyzer/netselect: Respect CC, use CFLAGS while linking
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Fixes: https://bugs.gentoo.org/698312 Reported-by: Peter Levine Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/netselect/netselect-0.4-r1.ebuild')
-rw-r--r--net-analyzer/netselect/netselect-0.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/netselect/netselect-0.4-r1.ebuild b/net-analyzer/netselect/netselect-0.4-r1.ebuild
new file mode 100644
index 000000000000..20dbb56b53c2
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping"
+HOMEPAGE="http://apenwarr.ca/netselect/"
+SRC_URI="
+ https://github.com/apenwarr/${PN}/archive/${P}.tar.gz
+ ipv6? ( https://dev.gentoo.org/~jer/${P}-ipv6.patch.xz )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4-bsd.patch
+ "${FILESDIR}"/${PN}-0.4-flags.patch
+)
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ use ipv6 && eapply "${WORKDIR}"/${PN}-0.4-ipv6.patch
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ dobin netselect
+
+ if ! use prefix ; then
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ fi
+
+ dodoc HISTORY README
+
+ doman netselect.1
+}