summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-12-04 14:39:44 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-12-04 14:40:12 +0100
commitb43d26a5cae31f79db6e7c6d3949d51c1b553216 (patch)
tree9c94a535559395ce839222f2ea3dd0f9d50c77a3 /net-analyzer
parentmedia-libs/libgphoto2: fix patch filename (diff)
downloadgentoo-b43d26a5cae31f79db6e7c6d3949d51c1b553216.tar.gz
gentoo-b43d26a5cae31f79db6e7c6d3949d51c1b553216.tar.bz2
gentoo-b43d26a5cae31f79db6e7c6d3949d51c1b553216.zip
net-analyzer/zabbix: drop fping suid check in postinst
The check is not necessary as we require fping[suid] if USE=server or USE=proxy. Furthermore, the check is broken since fping could be installed with filecaps, which results in /usr/bin/fping not being suid but using file capabilities instead. Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.49.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.50.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.38.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.39.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.40.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-6.0.22.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-6.0.23.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-6.0.24.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-6.4.7.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-6.4.8.ebuild21
-rw-r--r--net-analyzer/zabbix/zabbix-6.4.9.ebuild21
11 files changed, 0 insertions, 231 deletions
diff --git a/net-analyzer/zabbix/zabbix-4.0.49.ebuild b/net-analyzer/zabbix/zabbix-4.0.49.ebuild
index 96f83a23947e..4f3236d0fe78 100644
--- a/net-analyzer/zabbix/zabbix-4.0.49.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.49.ebuild
@@ -340,27 +340,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-4.0.50.ebuild b/net-analyzer/zabbix/zabbix-4.0.50.ebuild
index 7c31bf7c6aee..127516244499 100644
--- a/net-analyzer/zabbix/zabbix-4.0.50.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.50.ebuild
@@ -340,27 +340,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-5.0.38.ebuild b/net-analyzer/zabbix/zabbix-5.0.38.ebuild
index 4264bc9df136..b16468daa5d8 100644
--- a/net-analyzer/zabbix/zabbix-5.0.38.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.38.ebuild
@@ -372,27 +372,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-5.0.39.ebuild b/net-analyzer/zabbix/zabbix-5.0.39.ebuild
index c14c0d9f7e31..f6e20da5e1f4 100644
--- a/net-analyzer/zabbix/zabbix-5.0.39.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.39.ebuild
@@ -372,27 +372,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-5.0.40.ebuild b/net-analyzer/zabbix/zabbix-5.0.40.ebuild
index 391cccd87bd4..ec9213f28600 100644
--- a/net-analyzer/zabbix/zabbix-5.0.40.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.40.ebuild
@@ -372,27 +372,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-6.0.22.ebuild b/net-analyzer/zabbix/zabbix-6.0.22.ebuild
index 93ca25c13a37..040a10ca07dd 100644
--- a/net-analyzer/zabbix/zabbix-6.0.22.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.0.22.ebuild
@@ -375,27 +375,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-6.0.23.ebuild b/net-analyzer/zabbix/zabbix-6.0.23.ebuild
index 140c978243b0..547968bc7d14 100644
--- a/net-analyzer/zabbix/zabbix-6.0.23.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.0.23.ebuild
@@ -375,27 +375,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-6.0.24.ebuild b/net-analyzer/zabbix/zabbix-6.0.24.ebuild
index fe2ed884f7c1..3f8ff4ea9877 100644
--- a/net-analyzer/zabbix/zabbix-6.0.24.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.0.24.ebuild
@@ -375,27 +375,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-6.4.7.ebuild b/net-analyzer/zabbix/zabbix-6.4.7.ebuild
index 1e6d6a3c6c1f..9463166f372f 100644
--- a/net-analyzer/zabbix/zabbix-6.4.7.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.4.7.ebuild
@@ -376,27 +376,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-6.4.8.ebuild b/net-analyzer/zabbix/zabbix-6.4.8.ebuild
index e60071e9b8a6..05728e16dff8 100644
--- a/net-analyzer/zabbix/zabbix-6.4.8.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.4.8.ebuild
@@ -376,27 +376,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {
diff --git a/net-analyzer/zabbix/zabbix-6.4.9.ebuild b/net-analyzer/zabbix/zabbix-6.4.9.ebuild
index 30c139d2d3c5..5fe722d26411 100644
--- a/net-analyzer/zabbix/zabbix-6.4.9.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.4.9.ebuild
@@ -376,27 +376,6 @@ pkg_postinst() {
elog "zabbix-trapper 10051/tcp Zabbix Trapper"
elog "zabbix-trapper 10051/udp Zabbix Trapper"
elog
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ;;
- esac
- fi
}
pkg_prerm() {