summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-10-13 02:01:23 +0200
committerLouis Sautier <sbraz@gentoo.org>2022-10-13 02:01:39 +0200
commite7e48c6bbd28c76dd222e7bc93dcd4e3bec04b35 (patch)
tree8a2f22a7c1215d465f24bab2c7dbaac5fda93850 /net-analyzer
parentmedia-libs/shaderc: Stabilize 2022.2 amd64, #876897 (diff)
downloadgentoo-e7e48c6bbd28c76dd222e7bc93dcd4e3bec04b35.tar.gz
gentoo-e7e48c6bbd28c76dd222e7bc93dcd4e3bec04b35.tar.bz2
gentoo-e7e48c6bbd28c76dd222e7bc93dcd4e3bec04b35.zip
net-analyzer/nagios-plugins-linux-madrisan: add 31
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/Manifest1
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-31.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/Manifest b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
index 985aed02d71a..e2a504d8820e 100644
--- a/net-analyzer/nagios-plugins-linux-madrisan/Manifest
+++ b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
@@ -1,2 +1,3 @@
DIST nagios-plugins-linux-madrisan-29.tar.xz 392700 BLAKE2B edc93bfb113cb12ce8a345e38627881decb952cb1e7a948dcdced2aaa9c940956b75a7c8f7ad1b72daac132236ab27762b6f8b14a5098eaac648bafae6dfdb33 SHA512 412464b894fe2a0953e495c7c87604ed6b282f65fd1988043757b162ba4fecf9e8f9740e7e09ec2dad8ba8d80fa928df4d7e644260538117d19776f4883045f6
DIST nagios-plugins-linux-madrisan-30.tar.xz 391164 BLAKE2B 3b16d0e61a68153fa90bed4c3540d9457546d2448b3b0da2b9313cd99e9b65f44c6f8d52322500570510171a049759ab85855f262d0581c6f926a96fbfe268dd SHA512 c02f81b6bbd4a0453780d9301a5cd1be67b9640e1b75d06c626a433b6e544fb4649c9b14e8e9a2c84dc6917aaf2011fb9a864ef36fef661bbcd673fa00bc5d57
+DIST nagios-plugins-linux-madrisan-31.tar.xz 401556 BLAKE2B 5eca1e96f14b518d9ab5304bb2a54ba47f194bf22cea8445d7fef0769c3b14c800e4ed24c5c0ca32f0daf53aa81a0bd52234478c606a8d2d1a12e96abb90179c SHA512 34d8ae400766e9c7ddd246998f004a50c87ec9ad8dc13deb8e31fc6fcfa07fbe5af2f091d0523b93d06b26438d1a25240bd82d60946e5897bc257fff7c1b73d0
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-31.ebuild b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-31.ebuild
new file mode 100644
index 000000000000..6e71445b286d
--- /dev/null
+++ b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-31.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="nagios-plugins-linux"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Additional and alternative Nagios plugins for Linux"
+HOMEPAGE="https://github.com/madrisan/nagios-plugins-linux"
+SRC_URI="https://github.com/madrisan/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl varlink"
+
+DEPEND="
+ curl? ( net-misc/curl:0= )
+ varlink? ( dev-libs/libvarlink:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # Avoid collision with net-analyzer/monitoring-plugins
+ # and net-analyzer/nagios-plugins
+ sed -ri "s/check_(load|swap|uptime|users)/&_madrisan/" plugins/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/nagios/plugins"
+ # Most options are already defaults for Gentoo
+ --disable-hardening
+ $(use_enable curl libcurl)
+ $(use_enable varlink libvarlink)
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake check VERBOSE=1
+}