summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-25 15:05:37 +0000
committerSam James <sam@gentoo.org>2024-03-25 15:06:24 +0000
commit1c956177bce251cc4157fbd0948dfffe085b7ceb (patch)
treeacb0df1750cbd16a0320709e9522a750f9d6ca44 /net-fs
parentapp-editors/emacs: Backport security fixes from Emacs 29.3 (diff)
downloadgentoo-1c956177bce251cc4157fbd0948dfffe085b7ceb.tar.gz
gentoo-1c956177bce251cc4157fbd0948dfffe085b7ceb.tar.bz2
gentoo-1c956177bce251cc4157fbd0948dfffe085b7ceb.zip
net-fs/cifs-utils: filter -fno-semantic-interposition
With >=glibc-2.38, it uses that strlcpy. Closes: https://bugs.gentoo.org/927809 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.15-r1.ebuild7
-rw-r--r--net-fs/cifs-utils/cifs-utils-7.0-r1.ebuild7
-rw-r--r--net-fs/cifs-utils/cifs-utils-7.0.ebuild7
3 files changed, 15 insertions, 6 deletions
diff --git a/net-fs/cifs-utils/cifs-utils-6.15-r1.ebuild b/net-fs/cifs-utils/cifs-utils-6.15-r1.ebuild
index 9e39096264da..469484d3dbd1 100644
--- a/net-fs/cifs-utils/cifs-utils-6.15-r1.ebuild
+++ b/net-fs/cifs-utils/cifs-utils-6.15-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit autotools bash-completion-r1 linux-info pam python-single-r1
+inherit autotools bash-completion-r1 flag-o-matic linux-info pam python-single-r1
DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
HOMEPAGE="https://wiki.samba.org/index.php/LinuxCIFS_utils https://git.samba.org/cifs-utils.git/?p=cifs-utils.git"
@@ -77,6 +77,9 @@ src_prepare() {
}
src_configure() {
+ # bug #927809
+ filter-flags -fno-semantic-interposition
+
local myeconfargs=(
--enable-man
--enable-smbinfo
diff --git a/net-fs/cifs-utils/cifs-utils-7.0-r1.ebuild b/net-fs/cifs-utils/cifs-utils-7.0-r1.ebuild
index 0dc48d00b48e..8720d8f3a066 100644
--- a/net-fs/cifs-utils/cifs-utils-7.0-r1.ebuild
+++ b/net-fs/cifs-utils/cifs-utils-7.0-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit autotools bash-completion-r1 linux-info pam python-single-r1
+inherit autotools bash-completion-r1 flag-o-matic linux-info pam python-single-r1
DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
HOMEPAGE="https://wiki.samba.org/index.php/LinuxCIFS_utils https://git.samba.org/cifs-utils.git/?p=cifs-utils.git"
@@ -78,6 +78,9 @@ src_prepare() {
}
src_configure() {
+ # bug #927809
+ filter-flags -fno-semantic-interposition
+
local myeconfargs=(
--enable-man
--enable-smbinfo
diff --git a/net-fs/cifs-utils/cifs-utils-7.0.ebuild b/net-fs/cifs-utils/cifs-utils-7.0.ebuild
index 9e39096264da..469484d3dbd1 100644
--- a/net-fs/cifs-utils/cifs-utils-7.0.ebuild
+++ b/net-fs/cifs-utils/cifs-utils-7.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit autotools bash-completion-r1 linux-info pam python-single-r1
+inherit autotools bash-completion-r1 flag-o-matic linux-info pam python-single-r1
DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
HOMEPAGE="https://wiki.samba.org/index.php/LinuxCIFS_utils https://git.samba.org/cifs-utils.git/?p=cifs-utils.git"
@@ -77,6 +77,9 @@ src_prepare() {
}
src_configure() {
+ # bug #927809
+ filter-flags -fno-semantic-interposition
+
local myeconfargs=(
--enable-man
--enable-smbinfo