summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/bobotpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/bobotpp')
-rw-r--r--net-irc/bobotpp/Manifest1
-rw-r--r--net-irc/bobotpp/bobotpp-2.2.3.ebuild54
-rw-r--r--net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch15
-rw-r--r--net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch13
-rw-r--r--net-irc/bobotpp/metadata.xml5
5 files changed, 88 insertions, 0 deletions
diff --git a/net-irc/bobotpp/Manifest b/net-irc/bobotpp/Manifest
new file mode 100644
index 000000000000..84104fd16679
--- /dev/null
+++ b/net-irc/bobotpp/Manifest
@@ -0,0 +1 @@
+DIST bobotpp-2.2.3.tar.gz 301675 SHA256 b45e84529b4417d31686e355951e0d4ceb7f0bb470f5c6498adb530f50a6d908 SHA512 473728350727da9225035c4a40303e3656f27d40786558b6a12939b22be56db9c3822a48ac1463a4baef6f45f5c9cf0ae90fdad0e9adc465c185ce1491034586 WHIRLPOOL 5acd2b5e4bd38f38d67196f386bc567c4acd621fce2b1b333107efa45c11a9417f06609823c7d9f5a022812e3f4f9a9acbb86f1a24c65d84ac2a8480a17ca780
diff --git a/net-irc/bobotpp/bobotpp-2.2.3.ebuild b/net-irc/bobotpp/bobotpp-2.2.3.ebuild
new file mode 100644
index 000000000000..cf2adf8475cd
--- /dev/null
+++ b/net-irc/bobotpp/bobotpp-2.2.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools autotools-utils eutils
+
+DESCRIPTION="A flexible IRC bot scriptable in scheme"
+HOMEPAGE="http://unknownlamer.org/code/bobot.html"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="guile"
+
+DEPEND="guile? ( dev-scheme/guile )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.2-asneeded.patch \
+ "${FILESDIR}"/${P}-stdout.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-crypt
+ $(use_enable guile scripting)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dosym bobot++.info /usr/share/info/bobotpp.info
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml documentation/index.html
+
+ docinto examples/config
+ dodoc examples/config/*
+
+ docinto examples/scripts
+ dodoc examples/scripts/*
+}
+
+pkg_postinst() {
+ elog "You can find a sample configuration file set in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/example-config"
+}
diff --git a/net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch b/net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch
new file mode 100644
index 000000000000..e960e008f187
--- /dev/null
+++ b/net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch
@@ -0,0 +1,15 @@
+--- bobotpp-2.2.2.orig/configure.ac 2006-06-29 02:02:46.000000000 +0200
++++ bobotpp-2.2.2/configure.ac 2009-10-15 19:31:42.058285332 +0200
+@@ -58,9 +58,9 @@
+ AC_CPP_STL_IOSBASE
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(crypt, crypt, [LDFLAGS="-lcrypt $LDFLAGS]")
+-AC_CHECK_LIB(socket, socket, [LDFLAGS="-lsocket $LDFLAGS]")
+-AC_CHECK_LIB(nsl, connect, [LDFLAGS="-lnsl $LDFLAGS]")
++AC_CHECK_LIB(crypt, crypt)
++AC_CHECK_LIB(socket, socket)
++AC_CHECK_LIB(nsl, connect)
+
+ dnl CC++ is special (no function to check_lib on
+ dnl AC_CHECK_PROG(CCGNU_FOUND, [ccgnu2-config],
diff --git a/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch b/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch
new file mode 100644
index 000000000000..8bbb78be966c
--- /dev/null
+++ b/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch
@@ -0,0 +1,13 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Reduce amount of noise printed to stdout.
+
+--- a/source/Utils.C
++++ b/source/Utils.C
+@@ -97,7 +97,6 @@
+ if (host == "") host = "*";
+ }
+
+- std::cout << nick + "!" + user + "@" + host << std::endl;
+
+ return nick + "!" + user + "@" + host;
+ }
diff --git a/net-irc/bobotpp/metadata.xml b/net-irc/bobotpp/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/bobotpp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>