summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/charybdis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/charybdis')
-rw-r--r--net-irc/charybdis/Manifest3
-rw-r--r--net-irc/charybdis/charybdis-3.3.0.ebuild95
-rw-r--r--net-irc/charybdis/charybdis-3.4.2.ebuild90
-rw-r--r--net-irc/charybdis/files/charybdis.confd7
-rw-r--r--net-irc/charybdis/files/charybdis.initd39
-rw-r--r--net-irc/charybdis/metadata.xml15
6 files changed, 249 insertions, 0 deletions
diff --git a/net-irc/charybdis/Manifest b/net-irc/charybdis/Manifest
new file mode 100644
index 000000000000..8ea64c7a12c3
--- /dev/null
+++ b/net-irc/charybdis/Manifest
@@ -0,0 +1,3 @@
+DIST charybdis-3.3.0-patches.tar.bz2 10070 SHA256 ec51bbd99dc8ee7b911bc232ae8e35c99f0d4b0b25562bc7991fbfe9dbe3ad28 SHA512 e78c66b7d1c91a9a2c47a6ebb95e3c019e7182cda7115417fd6fc4e9f45dfabdb1467f5b19fa347d56cdbda97f66f7acab52d8ac560d5b3d3e179f7a7158c6da WHIRLPOOL a2bc4b258265347eb3f243d8b933084235717507b52f0c244062e74c017d34f13fcb2abf89ebde62760b49bc95c9d6df22e13a9c7c3e5526bdbf5c131662ef79
+DIST charybdis-3.3.0.tbz2 1478877 SHA256 b5feae88c031dee799144fbfde9d64f3ace4c979c337a1047677a17600dddab1 SHA512 450f1869405a0ea1379c4b189df3a62524ce6656ef5fd1371f705814e9404b5386e2fc4a9ba548ee1027fb73464c06b2c68bad142570042bbc0381723a306eae WHIRLPOOL 909e87b52e9b717c4de91ab737663b86c30372bdb5e80f23ecf76f9c3320adbaeb3c0ad991ff1b74958114041fdd9aa73f8870efd166ae4af851384eed4e56ed
+DIST charybdis-3.4.2.tbz2 1526229 SHA256 8a38e67072d90147c40202918c82237765e339cbc849456da54994ce6e31b754 SHA512 4bd4126cbb023e8ca1ec3003d92893dd44f9bdd8ce5d3fb471fed0b62eb4aa5ff410a6e769ee7daab4864492d49ff594e3e8c7fea05318eb2308efc2195dc8a3 WHIRLPOOL ac098f73169662cda2a9829f2204a6b1eac56b18d023b9049f82a427edd8ab6888133ce2959815a41104a68a7f22097c83cdc84413bbe66d6a3b8f4fe6979e41
diff --git a/net-irc/charybdis/charybdis-3.3.0.ebuild b/net-irc/charybdis/charybdis-3.3.0.ebuild
new file mode 100644
index 000000000000..871a365bed70
--- /dev/null
+++ b/net-irc/charybdis/charybdis-3.3.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils multilib user
+
+DESCRIPTION="The atheme project's IRCd based on ratbox"
+HOMEPAGE="http://atheme.org/project/charybdis http://www.stack.nl/~jilles/irc/#charybdis"
+SRC_URI="http://www.stack.nl/~jilles/irc/${P}.tbz2
+ http://dev.gentoo.org/~binki/distfiles/${CATEGORY}/${PN}/${P}-patches.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +ipv6 largenet ssl zlib"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 "${EPREFIX}"/usr ${PN}
+}
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+
+ eautoreconf
+
+ # Fill the example configuration file with proper paths.
+ sed -i \
+ -e "s:path =.*modules:path = \"$(get_libdir)/${PN}/modules:g" \
+ -e "s:etc/:../etc/${PN}/:g" \
+ -e "s:logs/:../var/log/charybdis/:g" \
+ -e "s:test\.\(cert\|key\):ssl.\1:g" \
+ doc/example.conf \
+ doc/reference.conf \
+ || die
+}
+
+src_configure() {
+ econf \
+ ac_cv_prog_cc_g=no \
+ --disable-gnutls \
+ $(use_enable debug assert soft) \
+ $(use_enable debug iodebug) \
+ $(use_enable ipv6) \
+ $(use_enable !largenet small-net) \
+ $(use_enable ssl openssl) \
+ $(use_enable zlib) \
+ --with-program-prefix=charybdis- \
+ \
+ --enable-fhs-paths \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --libdir="${EPREFIX}"/usr/"$(get_libdir)"/${PN} \
+ --with-logdir="${EPREFIX}"/var/log/${PN} \
+ --with-moduledir="${EPREFIX}"/usr/"$(get_libdir)"/${PN}/modules \
+ --with-rundir="${EPREFIX}"/var/run
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ insinto etc/${PN}
+ newins doc/reference.conf ircd.conf
+
+ keepdir var/{lib,log}/${PN}
+
+ # Ensure that if `make install' created /var/run/${PN}, we still
+ # force the initscript to create that directory.
+ rm -rf "${D}"/var/run || die
+
+ # charybdis ircd needs writing to its state (bandb) and log directories
+ fowners :charybdis /var/{lib,log}/${PN}
+ fperms 770 /var/{lib,log}/${PN}
+
+ # ensure that charybdis can access but not modify its configuration
+ # while protecting it from others
+ fowners :charybdis /etc/${PN}{,/ircd.conf}
+ fperms 750 /etc/${PN}
+ fperms 640 /etc/${PN}/ircd.conf
+}
+
+pkg_postinst() {
+ elog "All of the charybdis binaries in PATH have been prefixed with"
+ elog "'charybdis-' to prevent file collisions."
+}
diff --git a/net-irc/charybdis/charybdis-3.4.2.ebuild b/net-irc/charybdis/charybdis-3.4.2.ebuild
new file mode 100644
index 000000000000..68a34c4acd4d
--- /dev/null
+++ b/net-irc/charybdis/charybdis-3.4.2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib user
+
+DESCRIPTION="The atheme project's IRCd based on ratbox"
+HOMEPAGE="http://atheme.org/project/charybdis http://www.stack.nl/~jilles/irc/#charybdis"
+SRC_URI="http://www.stack.nl/~jilles/irc/${P}.tbz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +ipv6 largenet ssl zlib"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 "${EPREFIX}"/usr ${PN}
+}
+
+src_prepare() {
+ # Fill the example configuration file with proper paths.
+ sed -i \
+ -e "s:path =.*modules:path = \"$(get_libdir)/${PN}/modules:g" \
+ -e "s:etc/:../etc/${PN}/:g" \
+ -e "s:logs/:../var/log/charybdis/:g" \
+ -e "s:test\.\(cert\|key\):ssl.\1:g" \
+ doc/example.conf \
+ doc/reference.conf \
+ || die
+}
+
+src_configure() {
+ econf \
+ ac_cv_prog_cc_g=no \
+ --disable-gnutls \
+ $(use_enable debug assert soft) \
+ $(use_enable debug iodebug) \
+ $(use_enable ipv6) \
+ $(use_enable !largenet small-net) \
+ $(use_enable ssl openssl) \
+ $(use_enable zlib) \
+ --with-program-prefix=charybdis- \
+ \
+ --enable-fhs-paths \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --libdir="${EPREFIX}"/usr/"$(get_libdir)"/${PN} \
+ --with-logdir="${EPREFIX}"/var/log/${PN} \
+ --with-moduledir="${EPREFIX}"/usr/"$(get_libdir)"/${PN}/modules \
+ --with-rundir="${EPREFIX}"/var/run
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ insinto etc/${PN}
+ newins doc/reference.conf ircd.conf
+
+ keepdir var/{lib,log}/${PN}
+
+ # Ensure that if `make install' created /var/run/${PN}, we still
+ # force the initscript to create that directory.
+ rm -rf "${D}"/var/run || die
+
+ # charybdis ircd needs writing to its state (bandb) and log directories
+ fowners :charybdis /var/{lib,log}/${PN}
+ fperms 770 /var/{lib,log}/${PN}
+
+ # ensure that charybdis can access but not modify its configuration
+ # while protecting it from others
+ fowners :charybdis /etc/${PN}{,/ircd.conf}
+ fperms 750 /etc/${PN}
+ fperms 640 /etc/${PN}/ircd.conf
+}
+
+pkg_postinst() {
+ elog "All of the charybdis binaries in PATH have been prefixed with"
+ elog "'charybdis-' to prevent file collisions."
+}
diff --git a/net-irc/charybdis/files/charybdis.confd b/net-irc/charybdis/files/charybdis.confd
new file mode 100644
index 000000000000..b97c3f4bb88e
--- /dev/null
+++ b/net-irc/charybdis/files/charybdis.confd
@@ -0,0 +1,7 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Specify any extra options to pass to charybdis
+CHARYBDIS_OPTS=""
diff --git a/net-irc/charybdis/files/charybdis.initd b/net-irc/charybdis/files/charybdis.initd
new file mode 100644
index 000000000000..aae065530fff
--- /dev/null
+++ b/net-irc/charybdis/files/charybdis.initd
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_started_commands="reload"
+
+depend() {
+ use dns net
+ provide ircd
+}
+
+start() {
+ if ! [ -d /var/run/charybdis ]; then
+ ebegin "Creating /var/run/charybdis for ${SVCNAME}"
+ mkdir /var/run/charybdis \
+ && chown :charybdis /var/run/charybdis \
+ && chmod 770 /var/run/charybdis
+ eend $?
+ fi
+
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec /usr/bin/charybdis-ircd \
+ --user charybdis --pidfile /var/run/charybdis/ircd.pid \
+ ${CHARYBDIS_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --pidfile /var/run/charybdis/ircd.pid
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile /var/run/charybdis/ircd.pid
+ eend $?
+}
diff --git a/net-irc/charybdis/metadata.xml b/net-irc/charybdis/metadata.xml
new file mode 100644
index 000000000000..4740cb09d293
--- /dev/null
+++ b/net-irc/charybdis/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+ </maintainer>
+ <maintainer>
+ <email>jdhore@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="largenet">Enable support/tweaks for large networks</flag>
+ </use>
+</pkgmetadata>