summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-05-27 12:58:27 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-05-28 14:37:19 +0300
commit1a1d4895f5288b649093ac91c273e781be8bdb92 (patch)
tree9378467b0deaf04ae20f8697ee1ecc1075569ce6 /net-irc
parentnet-misc/seafile-client: version bump to 9.0.2_p1 (diff)
downloadgentoo-1a1d4895f5288b649093ac91c273e781be8bdb92.tar.gz
gentoo-1a1d4895f5288b649093ac91c273e781be8bdb92.tar.bz2
gentoo-1a1d4895f5288b649093ac91c273e781be8bdb92.zip
net-irc/kvirc: fix includes
Closes: https://bugs.gentoo.org/906940 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/kvirc/files/fixqprocess.patch29
-rw-r--r--net-irc/kvirc/kvirc-5.2_pre20220629000000.ebuild4
2 files changed, 33 insertions, 0 deletions
diff --git a/net-irc/kvirc/files/fixqprocess.patch b/net-irc/kvirc/files/fixqprocess.patch
new file mode 100644
index 000000000000..2127dcc3f1ce
--- /dev/null
+++ b/net-irc/kvirc/files/fixqprocess.patch
@@ -0,0 +1,29 @@
+commit b4405b0c3dbd00c31d20597360249966bfd627c9
+Author: Alexey Sokolov <sokolov@google.com>
+Date: Sat May 27 12:46:34 2023 +0100
+
+ Fix includes, QProcess is used not only without KDE
+
+ https://bugs.gentoo.org/906940
+
+diff --git a/src/modules/system/libkvisystem.cpp b/src/modules/system/libkvisystem.cpp
+index 2abab2c10..842d3fa3f 100644
+--- a/src/modules/system/libkvisystem.cpp
++++ b/src/modules/system/libkvisystem.cpp
+@@ -50,12 +50,13 @@
+ #endif
+
+ #ifdef COMPILE_KDE_SUPPORT
+-#include <KToolInvocation> // invokeTerminal() for system.runcmd
+-#else // tools we need to work around the absence of
++// invokeTerminal() for system.runcmd
++// tools we need to work around the absence of
++#include <KToolInvocation>
++#endif
+ // invokeTerminal()
+ #include <QProcess>
+ #include <QStringList>
+-#endif
+
+ PluginManager * g_pPluginManager;
+
diff --git a/net-irc/kvirc/kvirc-5.2_pre20220629000000.ebuild b/net-irc/kvirc/kvirc-5.2_pre20220629000000.ebuild
index a7cba86601de..71c722a5b2f7 100644
--- a/net-irc/kvirc/kvirc-5.2_pre20220629000000.ebuild
+++ b/net-irc/kvirc/kvirc-5.2_pre20220629000000.ebuild
@@ -80,6 +80,10 @@ fi
DOCS=()
+PATCHES=(
+ "${FILESDIR}/fixqprocess.patch"
+)
+
pkg_setup() {
if use python; then
python-single-r1_pkg_setup