summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/farstream
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/farstream')
-rw-r--r--net-libs/farstream/Manifest2
-rw-r--r--net-libs/farstream/farstream-0.1.2-r1.ebuild93
-rw-r--r--net-libs/farstream/farstream-0.1.2-r2.ebuild85
-rw-r--r--net-libs/farstream/farstream-0.2.7.ebuild67
-rw-r--r--net-libs/farstream/files/farstream-0.1.2-introspection-tag-order.patch132
-rw-r--r--net-libs/farstream/metadata.xml5
6 files changed, 384 insertions, 0 deletions
diff --git a/net-libs/farstream/Manifest b/net-libs/farstream/Manifest
new file mode 100644
index 000000000000..e0a26e7dd3f4
--- /dev/null
+++ b/net-libs/farstream/Manifest
@@ -0,0 +1,2 @@
+DIST farstream-0.1.2.tar.gz 1265972 SHA256 fa5a40597b47b59d124f7fd57f66704b030d576cdc0d90e107c7a592f05e73d9 SHA512 7d9ddde5d17205752a17298fb90cf855a828b2ae58746fbdc7e47749cee5e5eac4fd56f97f58251a5d253901cdd555e9cfade6016b6d92df99daefbe850e2910 WHIRLPOOL 273d20082152ff09adf8e64481b1b7c7ba7e6a24fc09addc219880fbee7f1e6b9845ce727c032fa3c364e8d2440736fd0324015426591b7e9766f11054828294
+DIST farstream-0.2.7.tar.gz 1309470 SHA256 dad0ed43cf94e71df558c23825abe57db59d1ee8d970ffaec5e2dbc2e7acbf7d SHA512 98c72eb9045bf7d0ee7d38fc1d7eea0b8ad942fc39843df075bf6f61bc0bed619aafb36ae08d55a6e61265bd47137ec75ffbfc2846c7cbcb4cbef187844426d8 WHIRLPOOL 515901c25aab04c5c7ae91a96285e36095844d730cf38e4f4f9aabfaeb7ed09a0a4ba5eddbfcb1b7c8ff52ed7f7f16cb7a7a2814d29953d8d5097bb06dd95abc
diff --git a/net-libs/farstream/farstream-0.1.2-r1.ebuild b/net-libs/farstream/farstream-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..0c33e7eb15c8
--- /dev/null
+++ b/net-libs/farstream/farstream-0.1.2-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="http://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="alpha ia64 sparc"
+IUSE="+introspection python msn test upnp"
+
+SLOT="0.1"
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+RESTRICT="test"
+
+COMMONDEPEND="
+ >=media-libs/gstreamer-0.10.33:0.10
+ >=media-libs/gst-plugins-base-0.10.33:0.10
+ >=dev-libs/glib-2.30:2
+ >=net-libs/libnice-0.1.0
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11 )
+ python? (
+ >=dev-python/pygobject-2.16:2
+ >=dev-python/gst-python-0.10.10:0.10 )
+ upnp? ( net-libs/gupnp-igd )
+"
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-0.10.17:0.10
+ >=media-libs/gst-plugins-bad-0.10.17:0.10
+ || (
+ >=media-plugins/gst-plugins-libnice-0.1.0:0.10
+ <=net-libs/libnice-0.1.3[gstreamer] )
+ msn? ( >=media-plugins/gst-plugins-mimic-0.10.17:0.10 )
+ !net-libs/farsight2
+"
+# This package is just a rename from farsight2
+
+MAKEOPTS="${MAKEOPTS} -j1" # Parallel is completely broken on this slot, bug #434618
+
+DEPEND="${COMMONDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? (
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-vorbis:0.10 )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Fix building with gobject-introspection-1.33.x, bug #425096
+ epatch "${FILESDIR}/${P}-introspection-tag-order.patch"
+}
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ use msn && plugins="${plugins},fsmsnconference"
+ econf --disable-static \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ # Parallel install fails, bug #434618 (fixed in latest slot)
+ emake -j1 install DESTDIR="${D}"
+ dodoc AUTHORS README ChangeLog
+
+ # Remove .la files since static libs are no longer being installed
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}
+
+src_test() {
+ # FIXME: do an out-of-tree build for tests if USE=-msn
+ if ! use msn; then
+ elog "Tests disabled without msn use flag"
+ return
+ fi
+
+ emake -j1 check
+}
diff --git a/net-libs/farstream/farstream-0.1.2-r2.ebuild b/net-libs/farstream/farstream-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..0e6440e6b082
--- /dev/null
+++ b/net-libs/farstream/farstream-0.1.2-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="http://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+
+IUSE="+introspection python test upnp"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+SLOT="0.1"
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+RESTRICT="test"
+
+COMMONDEPEND="
+ >=media-libs/gstreamer-0.10.33:0.10
+ >=media-libs/gst-plugins-base-0.10.33:0.10
+ >=dev-libs/glib-2.30:2
+ >=net-libs/libnice-0.1.0
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11 )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+ >=dev-python/gst-python-0.10.10:0.10[${PYTHON_USEDEP}] )
+ upnp? ( net-libs/gupnp-igd )
+"
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-0.10.17:0.10
+ >=media-libs/gst-plugins-bad-0.10.17:0.10
+ || (
+ >=media-plugins/gst-plugins-libnice-0.1.0:0.10
+ <=net-libs/libnice-0.1.3[gstreamer] )
+ !net-libs/farsight2
+"
+# This package is just a rename from farsight2
+
+MAKEOPTS="${MAKEOPTS} -j1" # Parallel is completely broken on this slot, bug #434618
+
+DEPEND="${COMMONDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? (
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-vorbis:0.10 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# FIXME: do an out-of-tree build for tests if USE=-msn
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix building with gobject-introspection-1.33.x, bug #425096
+ epatch "${FILESDIR}/${P}-introspection-tag-order.patch"
+}
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ econf --disable-static \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ # Parallel install fails, bug #434618 (fixed in latest slot)
+ emake -j1 install DESTDIR="${D}"
+ dodoc AUTHORS README ChangeLog
+
+ # Remove .la files since static libs are no longer being installed
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}
diff --git a/net-libs/farstream/farstream-0.2.7.ebuild b/net-libs/farstream/farstream-0.2.7.ebuild
new file mode 100644
index 000000000000..4828d308df54
--- /dev/null
+++ b/net-libs/farstream/farstream-0.2.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="http://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="+introspection test upnp"
+
+SLOT="0.2/5" # .so version
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+# FIXME: do an out-of-tree build for tests if USE=-msn
+RESTRICT="test"
+
+COMMONDEPEND="
+ >=media-libs/gstreamer-1.4:1.0
+ >=media-libs/gst-plugins-base-1.4:1.0
+ >=dev-libs/glib-2.32:2
+ >=net-libs/libnice-0.1.8
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11 )
+ upnp? ( >=net-libs/gupnp-igd-0.2:= )
+"
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-1.4:1.0
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ media-plugins/gst-plugins-libnice:1.0
+"
+DEPEND="${COMMONDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.18
+ virtual/pkgconfig
+ test? (
+ media-libs/gst-plugins-base:1.0[vorbis]
+ media-libs/gst-plugins-good:1.0 )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_compile() {
+ # Prevent sandbox violations, bug #539224
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ addpredict /dev
+ gnome2_src_compile
+}
diff --git a/net-libs/farstream/files/farstream-0.1.2-introspection-tag-order.patch b/net-libs/farstream/files/farstream-0.1.2-introspection-tag-order.patch
new file mode 100644
index 000000000000..3283e1fd2990
--- /dev/null
+++ b/net-libs/farstream/files/farstream-0.1.2-introspection-tag-order.patch
@@ -0,0 +1,132 @@
+From 39450457190675716c8e66700e35b05334a6a1a0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Olivier=20Cr=C3=AAte?= <olivier.crete@collabora.com>
+Date: Fri, 25 May 2012 17:06:59 -0400
+Subject: [PATCH] Gtk-doc tags belong after the description
+
+---
+ farstream/fs-session.c | 16 +++++++---------
+ farstream/fs-stream.c | 15 ++++++---------
+ 2 files changed, 13 insertions(+), 18 deletions(-)
+
+diff --git a/farstream/fs-session.c b/farstream/fs-session.c
+index 80794d1..abb1bc3 100644
+--- a/farstream/fs-session.c
++++ b/farstream/fs-session.c
+@@ -270,9 +270,6 @@ fs_session_class_init (FsSessionClass *klass)
+ /**
+ * FsSession:codec-preferences:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the current preferences list for the local codecs. It is
+ * set by the user to specify the codec options and priorities. The user may
+ * change its value with fs_session_set_codec_preferences() at any time
+@@ -283,6 +280,9 @@ fs_session_class_init (FsSessionClass *klass)
+ * or %FS_CODEC_ID_ANY. If the encoding name is "reserve-pt", then the
+ * payload type of the codec will be "reserved" and not be used by any
+ * dynamically assigned payload type.
++ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_CODEC_PREFERENCES,
+@@ -296,9 +296,6 @@ fs_session_class_init (FsSessionClass *klass)
+ /**
+ * FsSession:codecs:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the list of codecs used for this session. It will include the
+ * codecs and payload type used to receive media on this session. It will
+ * also include any configuration parameter that must be transmitted reliably
+@@ -317,6 +314,8 @@ fs_session_class_init (FsSessionClass *klass)
+ * It is a #GList of #FsCodec. User must free this codec list using
+ * fs_codec_list_destroy() when done.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_CODECS,
+@@ -329,9 +328,6 @@ fs_session_class_init (FsSessionClass *klass)
+ /**
+ * FsSession:codecs-without-config:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the same list of codecs as #FsSession:codecs without
+ * the configuration information that describes the data sent. It is suitable
+ * for configurations where a list of codecs is shared by many senders.
+@@ -349,6 +345,8 @@ fs_session_class_init (FsSessionClass *klass)
+ * It is a #GList of #FsCodec. User must free this codec list using
+ * fs_codec_list_destroy() when done.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_CODECS_WITHOUT_CONFIG,
+diff --git a/farstream/fs-stream.c b/farstream/fs-stream.c
+index b9e1320..110641d 100644
+--- a/farstream/fs-stream.c
++++ b/farstream/fs-stream.c
+@@ -176,13 +176,12 @@ fs_stream_class_init (FsStreamClass *klass)
+ /**
+ * FsStream:remote-codecs:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the list of remote codecs for this stream. They must be set by the
+ * user as soon as they are known using fs_stream_set_remote_codecs()
+ * (generally through external signaling). It is a #GList of #FsCodec.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_REMOTE_CODECS,
+@@ -195,15 +194,14 @@ fs_stream_class_init (FsStreamClass *klass)
+ /**
+ * FsStream:negotiated-codecs:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the list of negotiatied codecs, it is the same list as the list
+ * of #FsCodec from the parent #FsSession, except that the codec config data
+ * has been replaced with the data from the remote codecs for this stream.
+ * This is the list of #FsCodec used to receive data from this stream.
+ * It is a #GList of #FsCodec.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_NEGOTIATED_CODECS,
+@@ -216,9 +214,6 @@ fs_stream_class_init (FsStreamClass *klass)
+ /**
+ * FsStream:current-recv-codecs:
+ *
+- * Type: GLib.List(FsCodec)
+- * Transfer: full
+- *
+ * This is the list of codecs that have been received by this stream.
+ * The user must free the list if fs_codec_list_destroy().
+ * The "farstream-recv-codecs-changed" message is send on the #GstBus
+@@ -228,6 +223,8 @@ fs_stream_class_init (FsStreamClass *klass)
+ * also be emitted if the pad already exists, but the source material that
+ * will come to it is different.
+ *
++ * Type: GLib.List(FsCodec)
++ * Transfer: full
+ */
+ g_object_class_install_property (gobject_class,
+ PROP_CURRENT_RECV_CODECS,
+--
+1.7.8.6
+
diff --git a/net-libs/farstream/metadata.xml b/net-libs/farstream/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-libs/farstream/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>