summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-14 08:46:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-14 09:00:55 +0200
commit2b9e39183630c588f793d3f3fe3a956cea695181 (patch)
tree8eb9fcfc601248f35756b0f4a496bb098a86943f /net-libs/libaccounts-glib
parentsys-apps/portage: Stabilize 3.0.36 arm, #869887 (diff)
downloadgentoo-2b9e39183630c588f793d3f3fe3a956cea695181.tar.gz
gentoo-2b9e39183630c588f793d3f3fe3a956cea695181.tar.bz2
gentoo-2b9e39183630c588f793d3f3fe3a956cea695181.zip
net-libs/libaccounts-glib: add 1.26, EAPI-8, python3_11
Fix project version manually. QA notice filed upstream: https://gitlab.com/accounts-sso/libaccounts-glib/-/issues/13 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libaccounts-glib')
-rw-r--r--net-libs/libaccounts-glib/Manifest1
-rw-r--r--net-libs/libaccounts-glib/files/libaccounts-glib-1.26-project-version.patch8
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.26.ebuild63
3 files changed, 72 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/Manifest b/net-libs/libaccounts-glib/Manifest
index 78431778763f..69deda66f437 100644
--- a/net-libs/libaccounts-glib/Manifest
+++ b/net-libs/libaccounts-glib/Manifest
@@ -1 +1,2 @@
DIST libaccounts-glib-1.25.tar.gz 117337 BLAKE2B 72e6e15b63eea4d5b2a3e994779a4636bee859c6d395c8c9f65120cfee1c25a5708971b438010f668eefee20735b01e9f9f4e1ac4cb55495a06143d20198e422 SHA512 cc8b493d246f99300ee614fed93258378ecdbe9c518a958a59827ee8f74559b1ee3683acfb85f59aa91390275497fb35041da2be47f27f24f96e1efd5d6d2e20
+DIST libaccounts-glib-1.26.tar.gz 117365 BLAKE2B a3c7bf4058372001079c9c153b30f947882521f1f9680a63db2883307e998335a1e646112dc8a51640824f238d871d96da2c18b4ef175c837cebfe056ded2cbb SHA512 c08a11087745ba771e539b61de57693390960ad6b4e8217c159be49d31bd7f8856fffa835e7a230f352049bbf7cec9184ff225e74bbc195964221d3d9d49743b
diff --git a/net-libs/libaccounts-glib/files/libaccounts-glib-1.26-project-version.patch b/net-libs/libaccounts-glib/files/libaccounts-glib-1.26-project-version.patch
new file mode 100644
index 000000000000..82e8c6bbcbd4
--- /dev/null
+++ b/net-libs/libaccounts-glib/files/libaccounts-glib-1.26-project-version.patch
@@ -0,0 +1,8 @@
+--- a/meson.build
++++ b/meson.build
+@@ -1,4 +1,4 @@
+-project('libaccounts-glib', 'c', version: '1.25', license: 'LGPL2.1', meson_version: '>=0.48.0')
++project('libaccounts-glib', 'c', version: '1.26', license: 'LGPL2.1', meson_version: '>=0.48.0')
+
+ version_parts = meson.project_version().split('.')
+ api_version = '@0@.0'.format(version_parts[0])
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.26.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.26.ebuild
new file mode 100644
index 000000000000..66a87f221321
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.26.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit meson python-r1 vala
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://gitlab.com/accounts-sso/libaccounts-glib"
+SRC_URI="https://gitlab.com/accounts-sso/${PN}/-/archive/VERSION_${PV}/${PN}-VERSION_${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-VERSION_${PV}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# fails
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/gobject-introspection:=
+ dev-libs/libxml2
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/check
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.25-assert-failure.patch"
+ "${FILESDIR}/${P}-project-version.patch"
+)
+
+src_prepare() {
+ default
+ vala_setup --ignore-use
+
+ use doc || sed -e "/^subdir('docs')$/d" -i meson.build || die
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir meson_src_compile
+}
+
+src_install() {
+ einstalldocs
+ python_foreach_impl run_in_build_dir meson_src_install
+ python_foreach_impl python_optimize
+}