summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/peephole
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/peephole')
-rw-r--r--net-mail/peephole/Manifest1
-rw-r--r--net-mail/peephole/files/peephole-1.4-gcc4.patch14
-rw-r--r--net-mail/peephole/metadata.xml8
-rw-r--r--net-mail/peephole/peephole-1.5.ebuild34
4 files changed, 57 insertions, 0 deletions
diff --git a/net-mail/peephole/Manifest b/net-mail/peephole/Manifest
new file mode 100644
index 000000000000..9ac44baffb82
--- /dev/null
+++ b/net-mail/peephole/Manifest
@@ -0,0 +1 @@
+DIST peephole-1.5.tar.gz 351492 SHA256 7b2eac9ee5bbc797f3f41703a70ea323c3c4a7e573a89b49190bf14046d8ea4f
diff --git a/net-mail/peephole/files/peephole-1.4-gcc4.patch b/net-mail/peephole/files/peephole-1.4-gcc4.patch
new file mode 100644
index 000000000000..d73546da4b25
--- /dev/null
+++ b/net-mail/peephole/files/peephole-1.4-gcc4.patch
@@ -0,0 +1,14 @@
+diff --exclude='*.lo' --exclude=.libs --exclude=.deps --exclude=libtool --exclude=Makefile --exclude='*.o' --exclude='*.la' --exclude='config*' -Nru peephole-1.4.vanilla/src/grammar/local/local.c peephole-1.4/src/grammar/local/local.c
+--- peephole-1.4.vanilla/src/grammar/local/local.c 2006-02-03 14:23:46.000000000 +0100
++++ peephole-1.4/src/grammar/local/local.c 2006-02-03 14:25:13.000000000 +0100
+@@ -25,8 +25,8 @@
+ static struct wm_local *parse_local(char *path, char *name)
+ {
+ struct wm_config wmc = {
+- .wml NULL,
+- .path path
++ NULL,
++ path
+ };
+
+ char rc[80]; // FIXME: possible buffer overflow...
diff --git a/net-mail/peephole/metadata.xml b/net-mail/peephole/metadata.xml
new file mode 100644
index 000000000000..d6eb719e5b4b
--- /dev/null
+++ b/net-mail/peephole/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="sourceforge">peephole</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/peephole/peephole-1.5.ebuild b/net-mail/peephole/peephole-1.5.ebuild
new file mode 100644
index 000000000000..0f383b4c2b35
--- /dev/null
+++ b/net-mail/peephole/peephole-1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A daemon that polls your POP servers, checking if there are messages from specific people"
+HOMEPAGE="http://peephole.sourceforge.net/"
+SRC_URI="mirror://sourceforge/peephole/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~sparc x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/openssl-0.9.7d-r1"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4-gcc4.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+pkg_postinst() {
+ elog "Before you can use peephole you must copy"
+ elog "/etc/skel/.peephole.providers and /etc/skel/.peepholerc"
+ elog "to your home dir and edit them to suit your needs."
+}