summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-04-04 10:07:22 -0500
committerBen Kohler <bkohler@gentoo.org>2022-04-04 10:11:52 -0500
commit48ec4def073eaa898c361514736967ae72a44853 (patch)
tree72d3e248423487d0b588c2997832562adbdec665 /net-misc/dropbox
parentnet-misc/dropbox: drop 141.4.3299, 142.4.4197, 143.4.4161 (diff)
downloadgentoo-48ec4def073eaa898c361514736967ae72a44853.tar.gz
gentoo-48ec4def073eaa898c361514736967ae72a44853.tar.bz2
gentoo-48ec4def073eaa898c361514736967ae72a44853.zip
net-misc/dropbox: add 145.4.4921
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/dropbox')
-rw-r--r--net-misc/dropbox/Manifest2
-rw-r--r--net-misc/dropbox/dropbox-145.4.4921.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/dropbox/Manifest b/net-misc/dropbox/Manifest
index e279b871f53f..0cd38f6fe7bb 100644
--- a/net-misc/dropbox/Manifest
+++ b/net-misc/dropbox/Manifest
@@ -1,3 +1,5 @@
DIST DropboxGlyph_Blue.svg 605 BLAKE2B 6c488bd261293b22da98035935ddfa9247bedbc6f4da2f9fc2470af802c1f4f597ac88b01b5bef9e77e1e717267f633d6a04af2ccfd3c5f9dbff22fbceaf9a91 SHA512 9202344b904dcd7955e5a355dadf537d1544140d74f8a33bdc40e18e36661e3a474d11cf17613eaebf4e76c170d8413d99abdedfb8635784bcd6892b4b259712
DIST dropbox-lnx.x86-144.4.4491.tar.gz 102606173 BLAKE2B e662ffac51126b1541a448a32aa4885e4a9a300a48cda79b2cd26e9edcdc53c2cf76dd1e03be4bc7d44d2a7c11e2b7f32d2b89af6ded4c650af8f05ddd865753 SHA512 ed040ddc8883877dd28966691ac068e26cc57a89d9cd9c364b005afb6057c025ec7182f341e1d8c7c2edb1d65ad7ab71a8f39c17e2dcbf73a5af6eba1275986b
+DIST dropbox-lnx.x86-145.4.4921.tar.gz 102627045 BLAKE2B a048bce81530d3874f4139e6e98e787f4e2242da830b5a5a43e6ec5f5502ad91bd90bfd25d2068895d18487b516cbd1e35c2fc2cfee9a50f15aca20ea48f8f6b SHA512 3bc7059e5387862c9ccc720f620d7aa47b594c78360f7644b5312659056cbca7cd345c0ee784b4de20c2bcd5f47958a64cc0e0eb63200bdfa8b73e6c06156f0a
DIST dropbox-lnx.x86_64-144.4.4491.tar.gz 104875474 BLAKE2B 42dd986edcf1ae6b709f0a52872219618d771636dccd6f4d0ff0abd7302c8d9358ed0cc6f6f26fb007633a9696f6119c7aac80f631f6687203cd8ed85760f8e4 SHA512 4bef381d4ab177325cd089a854942814b8a7efd553b4f71980c17ea1312d8e9c9a64662ab6a99626254e50a195c2c66f5fc92f465f12881cbd4e89618e120d89
+DIST dropbox-lnx.x86_64-145.4.4921.tar.gz 104888508 BLAKE2B 11a91e4c0da4066e4d18daaf5e066c141bb480811a54e3aab8b7c6ef3a96faaee40d5d7007c871de7cc1bd5f402a03c2586de49a13ff2ce75d5bf1dbf120d1bd SHA512 f3f8805c7f98f5bc0010545be2daa9d8713253a5391494537b5c2a8e010b605f50a32ebf1dff473ce6e8768e5350a8b62310541197de24b44a4c5c2295d43c30
diff --git a/net-misc/dropbox/dropbox-145.4.4921.ebuild b/net-misc/dropbox/dropbox-145.4.4921.ebuild
new file mode 100644
index 000000000000..0c3e0f739306
--- /dev/null
+++ b/net-misc/dropbox/dropbox-145.4.4921.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop pax-utils systemd xdg
+
+DESCRIPTION="Dropbox daemon (pretends to be GUI-less)"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="
+ amd64? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86_64-${PV}.tar.gz )
+ x86? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86-${PV}.tar.gz )
+ https://www.dropbox.com/sh/42f8d4kq6yt5lte/AAD69lhaw6gy46W8HfQAm0GSa/Glyph/Dropbox/SVG/DropboxGlyph_Blue.svg
+"
+
+LICENSE="BSD-2 CC-BY-ND-3.0 FTL MIT LGPL-2 openssl dropbox"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE="selinux X"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/.*"
+QA_EXECSTACK="opt/dropbox/dropbox"
+
+BDEPEND="dev-util/patchelf"
+
+# Be sure to have GLIBCXX_3.4.9, #393125
+RDEPEND="
+ X? (
+ x11-themes/hicolor-icon-theme
+ )
+ selinux? ( sec-policy/selinux-dropbox )
+ app-arch/bzip2
+ dev-libs/glib:2
+ dev-libs/libffi-compat:6
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/wget
+ sys-libs/zlib
+ sys-libs/ncurses-compat:5
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libxcb
+"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${S}" || die
+ mv "${WORKDIR}"/.dropbox-dist/* "${S}" || die
+ mv "${S}"/dropbox-lnx.*-${PV}/* "${S}" || die
+ rmdir "${S}"/dropbox-lnx.*-${PV}/ || die
+ rmdir .dropbox-dist || die
+}
+
+src_prepare() {
+ default
+ # we supply all of these in RDEPEND
+ rm -vf libGL.so.1 libX11* libffi.so.6 || die
+ # some of these do not appear to be used
+ rm -vf libQt5{OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets}.so.5 \
+ PyQt5.QtPrintSupport.* PyQt5.QtQml.* PyQt5.QtQuick.* \
+ wmctrl libdrm.so.2 libpopt.so.0 || die
+ if use X ; then
+ mv images/hicolor/16x16/status "${T}" || die
+ else
+ rm -vrf images || die
+ fi
+ patchelf --set-rpath '$ORIGIN' \
+ apex._apex.*.so \
+ nucleus_python.*.so \
+ tprt.*.so \
+ || die
+ pax-mark cm dropbox
+ mv README ACKNOWLEDGEMENTS "${T}" || die
+}
+
+src_install() {
+ local targetdir="/opt/dropbox"
+
+ insinto "${targetdir}"
+ doins -r *
+ fperms a+x "${targetdir}"/{dropbox,dropboxd}
+ dosym "${targetdir}/dropboxd" "/opt/bin/dropbox"
+
+ if use X; then
+ doicon -s 16 -c status "${T}"/status
+ newicon -s scalable "${DISTDIR}/DropboxGlyph_Blue.svg" dropbox.svg
+ fi
+
+ make_desktop_entry "${PN}" "Dropbox" "dropboxstatus-logo"
+
+ newinitd "${FILESDIR}"/dropbox.initd dropbox
+ newconfd "${FILESDIR}"/dropbox.conf dropbox
+ systemd_newunit "${FILESDIR}"/dropbox_at.service-r2 "dropbox@.service"
+
+ dodoc "${T}"/{README,ACKNOWLEDGEMENTS}
+}
+
+pkg_postinst() {
+ einfo "Warning: while running, dropbox may attempt to autoupdate itself in"
+ einfo " your user's home directory. To prevent this, run the following as"
+ einfo " each user who will run dropbox:"
+ einfo ""
+ einfo "install -dm0 ~/.dropbox-dist"
+}