summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-07-05 23:20:33 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-07-05 23:20:33 -0700
commit25bb459da274d4d5e62e05a46feaf99147a08f6f (patch)
tree8c3de5d6b65b36b8dea35c37fc434e54eaad3f22 /net-misc/lldpd
parentnet-nds/openldap: fix version in ewarn (diff)
downloadgentoo-25bb459da274d4d5e62e05a46feaf99147a08f6f.tar.gz
gentoo-25bb459da274d4d5e62e05a46feaf99147a08f6f.tar.bz2
gentoo-25bb459da274d4d5e62e05a46feaf99147a08f6f.zip
net-misc/lldpd: add 1.0.17
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-misc/lldpd')
-rw-r--r--net-misc/lldpd/Manifest1
-rw-r--r--net-misc/lldpd/lldpd-1.0.17.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/net-misc/lldpd/Manifest b/net-misc/lldpd/Manifest
index 2ac27a995e7f..8d58693add2d 100644
--- a/net-misc/lldpd/Manifest
+++ b/net-misc/lldpd/Manifest
@@ -1 +1,2 @@
DIST lldpd-1.0.16.tar.gz 1967182 BLAKE2B 3a359ec6539087ab1ffa5e1f83b90cc375b047b6e404df21067621bac9c9e5bab4b04209e9111d72fc2486046fb1d4b6744c093342c908f9a6475cd0b5a33328 SHA512 4abd25d1d7325f0a963518d916139f39b9250c37dfd918819019cabaafcdbedbfa03c78da80d36a09a0f4b1d79d4ee5e8aee1d10596bcd5710cd0c1181ba27c1
+DIST lldpd-1.0.17.tar.gz 1983689 BLAKE2B e74a1cdd965b26e9bad509fefb66bddfd74028a7d5122e561aed51eeb1b42c26497ce07169218133e4b99f12f4e0951065280c4ea8e47d54ecb6a8e697104106 SHA512 8f6d6ea6a32cc0f238158a2d1f08224224bca250cf61f80e4d8b633c0471e4ff9a17a7a7d7f313f10d557a256c7419f54cbb3b78903b7bba3619f9c5b6c114c8
diff --git a/net-misc/lldpd/lldpd-1.0.17.ebuild b/net-misc/lldpd/lldpd-1.0.17.ebuild
new file mode 100644
index 000000000000..bd0f6ba2ac4e
--- /dev/null
+++ b/net-misc/lldpd/lldpd-1.0.17.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd bash-completion-r1 autotools tmpfiles
+
+DESCRIPTION="Implementation of IEEE 802.1ab (LLDP)"
+HOMEPAGE="https://lldpd.github.io/"
+SRC_URI="https://github.com/lldpd/lldpd/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/4.9.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdp doc +dot1 +dot3 edp fdp graph +lldpmed old-kernel sanitizers
+ seccomp sonmp snmp static-libs test readline valgrind xml"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-group/lldpd
+ acct-user/lldpd
+ dev-libs/libbsd
+ >=dev-libs/libevent-2.1.11:=
+ sys-libs/readline:0=
+ seccomp? ( sys-libs/libseccomp:= )
+ snmp? ( net-analyzer/net-snmp:=[extensible(+)] )
+ xml? ( dev-libs/libxml2:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ valgrind? ( dev-util/valgrind )
+"
+BDEPEND="virtual/pkgconfig
+ doc? (
+ graph? ( app-doc/doxygen[dot,doc] )
+ !graph? ( app-doc/doxygen )
+ )
+"
+
+REQUIRED_USE="
+ graph? ( doc )
+ test? ( snmp sanitizers )
+"
+
+# tests need root
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_valgrind_valgrind_h=$(usex valgrind)
+
+ econf \
+ --without-embedded-libevent \
+ --with-privsep-user=${PN} \
+ --with-privsep-group=${PN} \
+ --with-privsep-chroot=/run/${PN} \
+ --with-lldpd-ctl-socket=/run/${PN}.socket \
+ --with-lldpd-pid-file=/run/${PN}.pid \
+ $(use_enable cdp) \
+ $(use_enable doc doxygen-doc) \
+ $(use_enable doc doxygen-man) \
+ $(use_enable doc doxygen-pdf) \
+ $(use_enable doc doxygen-html) \
+ $(use_enable dot1) \
+ $(use_enable dot3) \
+ $(use_enable edp) \
+ $(use_enable fdp) \
+ $(use_enable graph doxygen-dot) \
+ $(use_enable lldpmed) \
+ $(use_enable old-kernel oldies) \
+ $(use_enable sonmp) \
+ $(use_enable static-libs static) \
+ $(use_with readline) \
+ $(use_enable sanitizers) \
+ $(use_with seccomp) \
+ $(use_with snmp) \
+ $(use_with xml)
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/${PN}-initd-5 ${PN}
+ newconfd "${FILESDIR}"/${PN}-confd-1 ${PN}
+ newbashcomp src/client/completion/lldpcli lldpcli
+
+ use doc && dodoc -r doxygen/html
+
+ insinto /etc
+ doins "${FILESDIR}/lldpd.conf"
+ keepdir /etc/${PN}.d
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ newtmpfiles "${FILESDIR}"/tmpfilesd ${PN}.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}