summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2021-03-25 00:29:03 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-30 16:13:16 +0300
commit3e25556d3cba9a086f7e6b65e57313da750ba6a3 (patch)
tree9e9fcc4d2f563db3fda6a9db71a73d469dc30601 /net-misc/seafile-client
parentapp-emulation/xen-tools: remove png/jpeg automagic (diff)
downloadgentoo-3e25556d3cba9a086f7e6b65e57313da750ba6a3.tar.gz
gentoo-3e25556d3cba9a086f7e6b65e57313da750ba6a3.tar.bz2
gentoo-3e25556d3cba9a086f7e6b65e57313da750ba6a3.zip
net-misc/seafile-client: fix build with dev-libs/glib-2.68.0
Closes: https://bugs.gentoo.org/777477 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/20108 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/seafile-client')
-rw-r--r--net-misc/seafile-client/files/seafile-client-8.0.1-glib-2.68.0.patch12
-rw-r--r--net-misc/seafile-client/seafile-client-8.0.1-r2.ebuild (renamed from net-misc/seafile-client/seafile-client-8.0.1-r1.ebuild)2
2 files changed, 13 insertions, 1 deletions
diff --git a/net-misc/seafile-client/files/seafile-client-8.0.1-glib-2.68.0.patch b/net-misc/seafile-client/files/seafile-client-8.0.1-glib-2.68.0.patch
new file mode 100644
index 000000000000..9b2dd42cc926
--- /dev/null
+++ b/net-misc/seafile-client/files/seafile-client-8.0.1-glib-2.68.0.patch
@@ -0,0 +1,12 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fbf1d2f..05e8d4d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,6 +6,7 @@ SET(SEAFILE_CLIENT_VERSION_MINOR 0)
+ SET(SEAFILE_CLIENT_VERSION_PATCH 1)
+ SET(PROJECT_VERSION "${SEAFILE_CLIENT_VERSION_MAJOR}.${SEAFILE_CLIENT_VERSION_MINOR}.${SEAFILE_CLIENT_VERSION_PATCH}")
+ ADD_DEFINITIONS(-DSEAFILE_CLIENT_VERSION=${PROJECT_VERSION})
++ADD_DEFINITIONS(-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_26)
+ INCLUDE(FindPkgConfig)
+
+ ## Build crash repoter on release build as default
diff --git a/net-misc/seafile-client/seafile-client-8.0.1-r1.ebuild b/net-misc/seafile-client/seafile-client-8.0.1-r2.ebuild
index b26abb8f4490..a36fc7d452eb 100644
--- a/net-misc/seafile-client/seafile-client-8.0.1-r1.ebuild
+++ b/net-misc/seafile-client/seafile-client-8.0.1-r2.ebuild
@@ -16,7 +16,6 @@ IUSE="libressl shibboleth test"
RESTRICT="!test? ( test )"
RDEPEND="dev-db/sqlite:3
- <dev-libs/glib-2.68.0
dev-libs/jansson
dev-libs/libevent
dev-qt/qtcore:5
@@ -37,6 +36,7 @@ PATCHES=(
"${FILESDIR}/${PN}-select-qt5.patch"
"${FILESDIR}/${PN}-7.0.9-libressl.patch"
"${FILESDIR}/${PN}-7.0.9-qt-5.15.patch"
+ "${FILESDIR}/${P}-glib-2.68.0.patch"
)
src_configure() {