summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-07-28 13:38:27 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-07-28 14:37:24 -0500
commit8320206b0cb48bbcea85ea1982cad9d8ade2a67f (patch)
tree529c70995f016f97065a23491fa5f347e3e223d6 /net-misc/spice-gtk
parentnet-misc/spice-gtk: drop old (diff)
downloadgentoo-8320206b0cb48bbcea85ea1982cad9d8ade2a67f.tar.gz
gentoo-8320206b0cb48bbcea85ea1982cad9d8ade2a67f.tar.bz2
gentoo-8320206b0cb48bbcea85ea1982cad9d8ade2a67f.zip
net-misc/spice-gtk: version bump to 0.35
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/Manifest1
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.36.ebuild146
2 files changed, 147 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/Manifest b/net-misc/spice-gtk/Manifest
index 2e098e999acd..5a5f917d9da4 100644
--- a/net-misc/spice-gtk/Manifest
+++ b/net-misc/spice-gtk/Manifest
@@ -1 +1,2 @@
DIST spice-gtk-0.35.tar.bz2 1437231 BLAKE2B f2731a794cf22b491bf858fff44506288af730b37f1c37e16ac3042d662373b4e4021808d5ca72440012fb36a5119ad11858cb8cf872b04376518487faebef49 SHA512 f0914a4a9baf892e39dab7d51aa9f5ab4dbb4ef01f09da158b20756f890745837d0a6c8c1f7897844e695be2ed01f3b1d04ada1cacc958b5cfadb0d4bf7c4729
+DIST spice-gtk-0.36.tar.bz2 1445914 BLAKE2B 1bd58d5bf6d000b8bc5f043273da66b73fcf0f1d3ad5ab8ca5580c5338fbfb489d0c13b3bfc0a4a7c7d429462095f7acf67579adc23e274ef0100d077fe38c36 SHA512 2f8fd15e18b902d7ec0bcfae09d189bd26a9eedd72c9e018b201132e454513849821c46746fcb5887ea0ba995d9ff168ee46482ca1d4dbdf7580787a1298e5bf
diff --git a/net-misc/spice-gtk/spice-gtk-0.36.ebuild b/net-misc/spice-gtk/spice-gtk-0.36.ebuild
new file mode 100644
index 000000000000..1fd2d973ec2b
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.36.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools eutils xdg-utils vala readme.gentoo-r1
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
+HOMEPAGE="https://www.spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+SRC_URI="https://www.spice-space.org/download/gtk/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus gstaudio gstvideo +gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard static-libs usbredir vala webdav libressl"
+
+REQUIRED_USE="?? ( pulseaudio gstaudio )"
+
+# TODO:
+# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
+# * use external pnp.ids as soon as that means not pulling in gnome-desktop
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ pulseaudio? ( media-sound/pulseaudio[glib] )
+ gstvideo? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ )
+ gstaudio? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ )
+ >=x11-libs/pixman-0.17.7
+ media-libs/opus
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
+ >=dev-libs/glib-2.46:2
+ >=x11-libs/cairo-1.2
+ virtual/jpeg:0=
+ sys-libs/zlib
+ introspection? ( dev-libs/gobject-introspection )
+ lz4? ( app-arch/lz4 )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( app-emulation/qemu[smartcard] )
+ usbredir? (
+ sys-apps/hwids
+ >=sys-apps/usbredir-0.4.2
+ virtual/libusb:1
+ virtual/libgudev:=
+ policykit? (
+ sys-apps/acl
+ >=sys-auth/polkit-0.110-r1
+ !~sys-auth/polkit-0.111 )
+ )
+ webdav? (
+ net-libs/phodav:2.0
+ >=net-libs/libsoup-2.49.91 )
+"
+DEPEND="${RDEPEND}
+ >=app-emulation/spice-protocol-0.14.0
+ dev-perl/Text-CSV
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+)
+
+src_prepare() {
+ # bug 558558
+ export GIT_CEILING_DIRECTORIES="${WORKDIR}"
+ echo GIT_CEILING_DIRECTORIES=${GIT_CEILING_DIRECTORIES}
+
+ default
+
+ eautoreconf
+
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ # Clean up environment, bug #586642
+ xdg_environment_reset
+
+ local myconf
+ myconf="
+ $(use_enable static-libs static)
+ $(use_enable introspection)
+ $(use_with sasl)
+ $(use_enable smartcard)
+ $(use_enable usbredir)
+ $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids)
+ $(use_with usbredir usb-acl-helper-dir /usr/libexec)
+ $(use_with gtk3 gtk 3.0)
+ $(use_enable policykit polkit)
+ $(use_enable pulseaudio pulse)
+ $(use_enable gstaudio)
+ $(use_enable gstvideo)
+ $(use_enable mjpeg builtin-mjpeg)
+ $(use_enable vala)
+ $(use_enable webdav)
+ $(use_enable dbus)
+ --disable-celt051
+ --disable-gtk-doc
+ --disable-maintainer-mode
+ --disable-werror
+ --enable-pie"
+
+ econf ${myconf}
+}
+
+src_compile() {
+ # Prevent sandbox violations, bug #581836
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ default
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ # Remove .la files if they're not needed
+ use static-libs || prune_libtool_files
+
+ make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
+ readme.gentoo_create_doc
+}