summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-12-15 11:02:40 +0500
committerPatrice Clement <monsieurp@gentoo.org>2018-01-14 16:48:28 +0100
commit2acbbbc26d72a0e838067e593e43d85864979fb6 (patch)
tree24987571bcbfccdd9fab919a1e0af5bb0910918a /net-misc/uftp
parentnet-misc/uftp: version bump to 4.9.4. (diff)
downloadgentoo-2acbbbc26d72a0e838067e593e43d85864979fb6.tar.gz
gentoo-2acbbbc26d72a0e838067e593e43d85864979fb6.tar.bz2
gentoo-2acbbbc26d72a0e838067e593e43d85864979fb6.zip
net-misc/uftp: additional enhancements.
More fixes for slot dependency, used PATCHES, migration to EAPI 6. Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'net-misc/uftp')
-rw-r--r--net-misc/uftp/uftp-3.7.1.ebuild12
-rw-r--r--net-misc/uftp/uftp-4.9.4.ebuild11
2 files changed, 11 insertions, 12 deletions
diff --git a/net-misc/uftp/uftp-3.7.1.ebuild b/net-misc/uftp/uftp-3.7.1.ebuild
index 4b12b671c17a..41aed30ba67b 100644
--- a/net-misc/uftp/uftp-3.7.1.ebuild
+++ b/net-misc/uftp/uftp-3.7.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Encrypted UDP based FTP with multicast"
HOMEPAGE="http://www.tcnj.edu/~bush/uftp.html"
@@ -14,12 +14,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+server ssl"
-DEPEND="ssl? ( dev-libs/openssl:0 )"
+DEPEND="ssl? ( dev-libs/openssl:0= )"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/${PN}-3.7_makefile.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${PN}-3.7_makefile.patch"
+)
src_compile() {
use ssl || local opt="NO_ENCRYPTION=1"
diff --git a/net-misc/uftp/uftp-4.9.4.ebuild b/net-misc/uftp/uftp-4.9.4.ebuild
index ffc9e730c616..74358db417d4 100644
--- a/net-misc/uftp/uftp-4.9.4.ebuild
+++ b/net-misc/uftp/uftp-4.9.4.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Encrypted UDP based FTP with multicast"
HOMEPAGE="http://uftp-multicast.sourceforge.net/"
@@ -14,13 +14,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+server ssl"
-DEPEND="ssl? ( dev-libs/openssl:0 )"
+DEPEND="ssl? ( dev-libs/openssl:0= )"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/${P}_makefile.patch"
- default
-}
+PATCHES=(
+ "${FILESDIR}/${P}_makefile.patch"
+)
src_compile() {
use ssl || local opt="NO_ENCRYPTION=1"