summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-18 17:20:47 +0100
committerSam James <sam@gentoo.org>2023-02-21 08:01:04 +0000
commit3f93e8f920ed105d633f45846aed6feb0f9cbcd0 (patch)
treea2af00aec8db97e3f91600615f9578a6a5b614c2 /net-misc
parentnet-dns/s6-dns: move dynamic libraries {/usr/lib* -> /lib*} (diff)
downloadgentoo-3f93e8f920ed105d633f45846aed6feb0f9cbcd0.tar.gz
gentoo-3f93e8f920ed105d633f45846aed6feb0f9cbcd0.tar.bz2
gentoo-3f93e8f920ed105d633f45846aed6feb0f9cbcd0.zip
net-misc/s6-networking: add 2.5.1.3
The package newly installs libraries to /lib* rather than /usr/lib* because utilities are installed to /bin, therefore, the should link shared libraries from /lib*. Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/s6-networking/Manifest1
-rw-r--r--net-misc/s6-networking/s6-networking-2.5.1.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/s6-networking/Manifest b/net-misc/s6-networking/Manifest
index 9837c8c86d42..51d10267b062 100644
--- a/net-misc/s6-networking/Manifest
+++ b/net-misc/s6-networking/Manifest
@@ -1,2 +1,3 @@
DIST s6-networking-2.5.1.1.tar.gz 110431 BLAKE2B 67776a8aa6b02d20ed73c8b8d45e255677c3688973f9ee5f8dcc0de5cfd26146b7ccdc680b22a57e2523d8ab3c08d6e090252e376d09c1edd971a391632d83a0 SHA512 a9c1970cad5b3aeee447cce7c858e8bd88ee378fe456cc68d032f195373dabf658eacf55d9fa39ec635e893116296c1c614b89d97c5045b90dbe745a52e24021
DIST s6-networking-2.5.1.2.tar.gz 114109 BLAKE2B 8c503fcd92957d9678ed45ac41f264dfb3aebf22006907f0ba1c0dfd2b698d5c60e43ed9d2201ef8feee66813c949e4a17d857d0314a32725edb38c01fc84060 SHA512 6b9198e3c4276f716bf7a3e4bfe5357b372eb01a1944e710a5c92a30033d78400ba18eb937dab2d03993deee91586dfd94f56e399d7ef58fc0ba85d8fd31f0d5
+DIST s6-networking-2.5.1.3.tar.gz 114490 BLAKE2B 09b74ff4c881e0c30162a1a01d0d372c0dab2888efaeb1cb97402c485fca2d1360aaa936b291237cab7d43af870d9653b833a9a0e57c57b23918b4128186b476 SHA512 abc90d374a24507998041fd8dcd5f9c2d91bf94046e3da8d324546471f482b5929d863bd2bc846581da32f6c980ef5c2e5d6780655c757316ef0b67e37c72a19
diff --git a/net-misc/s6-networking/s6-networking-2.5.1.3.ebuild b/net-misc/s6-networking/s6-networking-2.5.1.3.ebuild
new file mode 100644
index 000000000000..492f2d8e74d0
--- /dev/null
+++ b/net-misc/s6-networking/s6-networking-2.5.1.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Suite of small networking utilities for Unix systems"
+HOMEPAGE="https://www.skarnet.org/software/s6-networking/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="
+ dev-lang/execline:=
+ >=dev-libs/skalibs-2.13.0.0:=
+ net-dns/s6-dns:=
+ sys-apps/s6:=[execline]
+ ssl? ( dev-libs/libretls )
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir="/$(get_libdir)"
+ --libdir="/usr/$(get_libdir)/${PN}"
+ --with-dynlib="/$(get_libdir)"
+ --with-lib="/usr/$(get_libdir)/s6"
+ --with-lib="/usr/$(get_libdir)/s6-dns"
+ --with-lib="/usr/$(get_libdir)/skalibs"
+ --with-sysdeps="/usr/$(get_libdir)/skalibs"
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ $(use_enable ssl ssl libtls)
+ )
+
+ econf "${myconf[@]}"
+}