summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2025-01-08 21:06:27 +0400
committerYixun Lan <dlan@gentoo.org>2025-01-10 02:51:43 +0000
commit93b691d8c3627bd906d32589a32793691771e2bd (patch)
treeffada325979e2e06581c366c685b8d7a8d475265 /net-misc
parentwww-apps/gitea: drop 1.22.3 (diff)
downloadgentoo-93b691d8c3627bd906d32589a32793691771e2bd.tar.gz
gentoo-93b691d8c3627bd906d32589a32793691771e2bd.tar.bz2
gentoo-93b691d8c3627bd906d32589a32793691771e2bd.zip
net-misc/ofono: add 2.14
Version bump 2.14, fix gcc-14 compiling err, with CVE fixes. Closes: https://bugs.gentoo.org/923406 Closes: https://github.com/gentoo/gentoo/pull/40054 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ofono/Manifest1
-rw-r--r--net-misc/ofono/ofono-2.14.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/ofono/Manifest b/net-misc/ofono/Manifest
index 3d4f5395c13a..0dc59e3741ae 100644
--- a/net-misc/ofono/Manifest
+++ b/net-misc/ofono/Manifest
@@ -1,3 +1,4 @@
DIST ofono-2.1.tar.xz 1097624 BLAKE2B 574293a73061470eec322df7fa62d581e8e8d2c5b81e896bff52173a986733f448686186bc0400ccf256fb931e26a1fef6a664dafa8f64935f936c9347e4a054 SHA512 7227939c488c2a62f640d5a8279e0698935aa1df5a2a349e195df9a8d9d9123c73a7f1177aae022b4c805d266c24a9770784193100adffa45f6c36a3ed847bb1
+DIST ofono-2.14.tar.xz 1311452 BLAKE2B 96f3875d9a2f515f14b5b6b6b5576e38338fd4a4912c5c7ea2c9ab8ed0e2791e4d22b591f5eb3ed9ccc1cd133174cbc3787b7d57e9bd6161fd03ad1a1e3f17f2 SHA512 77466c9155753130465748660df66473ca13afee59441a27f3d7dde653e632fb142af294aa2272ea14ce9d4845b68b5e2d4a58a9534555819c92fe161b4ff893
DIST ofono-2.3.tar.xz 1216872 BLAKE2B e32ea09dbc8f0aa2ca3f322ffc34d9f9d06d862792b05a0f96ddba4ebe4038199ab40a4065582d68a35d2a5725646626bc36c8f9e83d89a42be8d76271144751 SHA512 0c53c2c441d28f89140192fe808769b3b27ef1ebf75e9ee9f9bfa53d0d102a47d11fcb364077ca88cdc598e8368924f477024b44a2adf795efe40b52ffe92dce
DIST ofono-2.9.tar.xz 1302044 BLAKE2B d468c179ead13ab75b5e9872c671bea3c5f7cd59242516ba432c323aefc423ea18fd401a236a7abacf0ff0f2c74c8921828496b8a74269a1dc246f893c89036b SHA512 181f4aad276ea5c5888c6b89187e27b65d42f002d1dd72091f377033bda82bada17364c49773d4a1fd62ea7940d27d7f796da561595b606abbf4b4ec220ae031
diff --git a/net-misc/ofono/ofono-2.14.ebuild b/net-misc/ofono/ofono-2.14.ebuild
new file mode 100644
index 000000000000..dc5af0dc80f3
--- /dev/null
+++ b/net-misc/ofono/ofono-2.14.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="https://git.kernel.org/pub/scm/network/ofono/ofono.git"
+SRC_URI="https://mirrors.edge.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+atmodem bluetooth +datafiles doc dundee examples +isimodem +phonesim +qmimodem tools +udev upower"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.6
+ >=dev-libs/glib-2.68
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ $(use_enable upower) \
+ --disable-maintainer-mode \
+ --disable-rilmodem \
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}