summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-12 21:15:22 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-12 22:54:43 +0100
commit9ed4f1dbc57094e753556b8688e999795f5b5546 (patch)
treed9d07a8351e71e3a5438a07dd685391b1c2ddc7d /net-misc
parentnet-misc/gallery-dl: drop old 1.27.7 (diff)
downloadgentoo-9ed4f1dbc57094e753556b8688e999795f5b5546.tar.gz
gentoo-9ed4f1dbc57094e753556b8688e999795f5b5546.tar.bz2
gentoo-9ed4f1dbc57094e753556b8688e999795f5b5546.zip
net-misc/gallery-dl: bump to 1.28.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.28.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index ee9e5b63783c..07c9b7361cb2 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -2,3 +2,4 @@ DIST gallery-dl-1.28.0.gh.tar.gz 766066 BLAKE2B d99cff290ea3b4c1e32a77a1eb3c751b
DIST gallery-dl-1.28.1.gh.tar.gz 768090 BLAKE2B 865f2ab4844202bd7643090783d173637d8eb1c58426074e012e44350a564ee44ff59a034533164306f89ba320bafb81ad91691dfda539c29ea6ab8359ed0d7f SHA512 438e03476dd9f8c551368c1de51911cf26de74e174f34f59579f8293d41112ca269cfd2f44a9eb7c0e012cfbb36beef8bd85aac0415147da518ed14d8009fc69
DIST gallery-dl-1.28.2.gh.tar.gz 774891 BLAKE2B 4abbcffa26f3ef15abc2385f5d84b7e11075e26751ce6cd2c9ee621530a21d55fe0f3356bcc0c022389f66189051d9baba3cf5e9867488f95bc9a6cb63e739d3 SHA512 4a7b7c11f98e333038640f0fc422aa0148a73f2163ff41f2778000499d33eafe2257ae143198b936627272ee281a3f14e458aa977094f24fea5751de68982251
DIST gallery-dl-1.28.3.gh.tar.gz 713131 BLAKE2B 0d5776b3a643bb58018bed427fca4d5dc0a892d601fdf58c2546cdbe014cf9a76d959fd54ce3ca38b919b9b54181158d2e0c3c183f4238cb3928eaac08d5063f SHA512 7390745f5bda7fa2864a113cf5484aeb28949a89e51847534941c19eaed8c971398411c5b70d12c3443c0b1af208e62e92c67f499deb3f0aa31b1f5d46b572e7
+DIST gallery-dl-1.28.4.gh.tar.gz 783110 BLAKE2B 954fcff7f65b6c835aba935ca3707987729cecbaeab8b99387280a661c3440f110bbd7e71c6d2d6e655825f99ef18f1dd803fd934c2b4cd0316dd597515f84d7 SHA512 eb0810dfdbd4eed5d7586af7649e4d72a98f4ed3060448a749c9cd17a3dfde1688782bbfd29738e551324b75dc4a0d2c8134539f5e4356bcfe4532694a67d690
diff --git a/net-misc/gallery-dl/gallery-dl-1.28.4.ebuild b/net-misc/gallery-dl/gallery-dl-1.28.4.ebuild
new file mode 100644
index 000000000000..8bb9fcbbb941
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.28.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{12..13} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+DISTUTILS_USE_PEP517="setuptools"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Tests against real servers, some tests always fail and some are subject to change.
+ rm ./test/test_{extractor,results}.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile_all() {
+ emake PYTHON="${EPYTHON}" ./data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}