summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/cups-pk-helper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/cups-pk-helper')
-rw-r--r--net-print/cups-pk-helper/Manifest2
-rw-r--r--net-print/cups-pk-helper/cups-pk-helper-0.2.4-r1.ebuild39
-rw-r--r--net-print/cups-pk-helper/cups-pk-helper-0.2.5.ebuild43
-rw-r--r--net-print/cups-pk-helper/files/cups-pk-helper-0.2.4-revert-stricter.patch55
-rw-r--r--net-print/cups-pk-helper/metadata.xml5
5 files changed, 144 insertions, 0 deletions
diff --git a/net-print/cups-pk-helper/Manifest b/net-print/cups-pk-helper/Manifest
new file mode 100644
index 000000000000..608bff00ab1f
--- /dev/null
+++ b/net-print/cups-pk-helper/Manifest
@@ -0,0 +1,2 @@
+DIST cups-pk-helper-0.2.4.tar.xz 149828 SHA256 d187dc994ff64621aa090d114170b292daa11122481d8b8adb7613b32ca4e3c3 SHA512 0e071cad5cb8177caefa973de754f015fca3f6bc291ff1f30b978be990f45e443ca91999a2c733aff616cd9a5fc3b4074e1e01a18dd049f6d9b629171587ba02 WHIRLPOOL 7b34eba1fd4fc26c81dafe1eb118e2aec7b6f955a3f0323866a732c85ae3046236e87deb7f6c0427c02bfaff6e823182f42909ac8b19817c6cb089e90127da32
+DIST cups-pk-helper-0.2.5.tar.xz 152620 SHA256 19221eed65a1e1498d396f3f99a783a95b21b4385e63b57a1f16e8728b8ca118 SHA512 9fc0af517755482dc3787ce87df389adee41b826c4ccca25df69474812523fa265c3dcf31fbc1a75c1b680b9b6490a9c358ac30aed7570fa98f5287f02a2be40 WHIRLPOOL b97000a948cdd82c46e83ab1e2be936068fc2eb28af13f672495c5827fe7ac7ddc4c5ac8df5fe146686aec386f513a2e36609727077254911a12162818003932
diff --git a/net-print/cups-pk-helper/cups-pk-helper-0.2.4-r1.ebuild b/net-print/cups-pk-helper/cups-pk-helper-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..2e3a348c4c8e
--- /dev/null
+++ b/net-print/cups-pk-helper/cups-pk-helper-0.2.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="PolicyKit helper to configure cups with fine-grained privileges"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/cups-pk-helper"
+SRC_URI="http://www.freedesktop.org/software/${PN}/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND=">=dev-libs/glib-2.30.0:2
+ net-print/cups
+ >=sys-auth/polkit-0.97"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus"
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.40.6
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ DOCS="AUTHORS HACKING NEWS README"
+
+ # Revert "Be stricter when validating printer names", bug #459596
+ epatch "${FILESDIR}/${P}-revert-stricter.patch"
+
+ # Regenerate dbus-codegen files to fix build with glib-2.30.x; bug #410773
+ rm -v src/cph-iface-mechanism.{c,h} || die
+}
diff --git a/net-print/cups-pk-helper/cups-pk-helper-0.2.5.ebuild b/net-print/cups-pk-helper/cups-pk-helper-0.2.5.ebuild
new file mode 100644
index 000000000000..63841edf3284
--- /dev/null
+++ b/net-print/cups-pk-helper/cups-pk-helper-0.2.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="PolicyKit helper to configure cups with fine-grained privileges"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/cups-pk-helper"
+SRC_URI="http://www.freedesktop.org/software/${PN}/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND="
+ >=dev-libs/glib-2.30.0:2
+ net-print/cups
+ >=sys-auth/polkit-0.97
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.40.6
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ DOCS="AUTHORS HACKING NEWS README"
+
+ # Regenerate dbus-codegen files to fix build with glib-2.30.x; bug #410773
+ rm -v src/cph-iface-mechanism.{c,h} || die
+
+ gnome2_src_prepare
+}
diff --git a/net-print/cups-pk-helper/files/cups-pk-helper-0.2.4-revert-stricter.patch b/net-print/cups-pk-helper/files/cups-pk-helper-0.2.4-revert-stricter.patch
new file mode 100644
index 000000000000..d20e3484baea
--- /dev/null
+++ b/net-print/cups-pk-helper/files/cups-pk-helper-0.2.4-revert-stricter.patch
@@ -0,0 +1,55 @@
+From f00aee0b43c31e94087668b23b72e873c660de5e Mon Sep 17 00:00:00 2001
+From: Vincent Untz <vuntz@suse.com>
+Date: Mon, 10 Dec 2012 09:44:31 +0000
+Subject: Revert "Be stricter when validating printer names"
+
+Apparently, this is way too strict. The lpadmin man page says:
+
+ CUPS allows printer names to contain any printable character except
+ SPACE, TAB, "/", or "#".
+
+So the previous code was (mostly) correct.
+
+This reverts commit 7bf9cbe43ef8f648f308e4760f75c2aa6b61fa8e.
+---
+diff --git a/src/cups.c b/src/cups.c
+index 96c2c20..09f0e7b 100644
+--- a/src/cups.c
++++ b/src/cups.c
+@@ -327,25 +327,23 @@ _cph_cups_is_printer_name_valid_internal (const char *name)
+ int i;
+ int len;
+
+- /* Quoting http://www.cups.org/documentation.php/doc-1.1/sam.html#4_1:
+- *
+- * The printer name must start with any printable character except
+- * " ", "/", and "@". It can contain up to 127 letters, numbers, and
+- * the underscore (_).
+- *
+- * The first part is a bit weird, as the second part is more
+- * restrictive. So we only consider the second part. */
+-
+ /* no empty string */
+ if (!name || name[0] == '\0')
+ return FALSE;
+
+ len = strlen (name);
+- if (len > 127)
++ /* no string that is too long; see comment at the beginning of the
++ * validation code block */
++ if (len > CPH_STR_MAXLEN)
+ return FALSE;
+
++ /* only printable characters, no space, no /, no # */
+ for (i = 0; i < len; i++) {
+- if (!g_ascii_isalnum (name[i]) && name[i] != '_')
++ if (!g_ascii_isprint (name[i]))
++ return FALSE;
++ if (g_ascii_isspace (name[i]))
++ return FALSE;
++ if (name[i] == '/' || name[i] == '#')
+ return FALSE;
+ }
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/net-print/cups-pk-helper/metadata.xml b/net-print/cups-pk-helper/metadata.xml
new file mode 100644
index 000000000000..dad9001338dc
--- /dev/null
+++ b/net-print/cups-pk-helper/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>