summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-01-27 16:41:11 -0500
committerRick Farina <zerochaos@gentoo.org>2020-01-27 16:41:26 -0500
commit0bc0717123b9e91048be7459bacb514b633e6070 (patch)
tree89f591e79f826ec4ec516345f379d344839dc78e /net-wireless/gqrx/gqrx-9999.ebuild
parentapp-office/wps-office: Bump to 11.1.0.9080 (diff)
downloadgentoo-0bc0717123b9e91048be7459bacb514b633e6070.tar.gz
gentoo-0bc0717123b9e91048be7459bacb514b633e6070.tar.bz2
gentoo-0bc0717123b9e91048be7459bacb514b633e6070.zip
net-wireless/gqrx: bump
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/gqrx/gqrx-9999.ebuild')
-rw-r--r--net-wireless/gqrx/gqrx-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/net-wireless/gqrx/gqrx-9999.ebuild b/net-wireless/gqrx/gqrx-9999.ebuild
index b9b3d7bb2cf0..0c8ea0281cd0 100644
--- a/net-wireless/gqrx/gqrx-9999.ebuild
+++ b/net-wireless/gqrx/gqrx-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils
@@ -34,6 +34,14 @@ DEPEND=">=net-wireless/gnuradio-3.7_rc:=[audio,analog,filter]
portaudio? ( media-libs/portaudio:= )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ if use !pulseaudio; then
+ sed -i 's/AUDIO_BACKEND = pulse/#AUDIO_BACKEND = pulse/' gqrx.pro || die
+ fi
+ cmake-utils_src_prepare
+ eapply_user
+}
+
src_configure() {
if use pulseaudio; then
LINUX_AUDIO_BACKEND=Pulseaudio
@@ -49,14 +57,6 @@ src_configure() {
cmake-utils_src_configure
}
-src_prepare() {
- if use !pulseaudio; then
- sed -i 's/AUDIO_BACKEND = pulse/#AUDIO_BACKEND = pulse/' gqrx.pro || die
- fi
- cmake-utils_src_prepare
- eapply_user
-}
-
src_install() {
dobin "${BUILD_DIR}"/src/gqrx
}