summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/mrbayes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/mrbayes')
-rw-r--r--sci-biology/mrbayes/Manifest1
-rw-r--r--sci-biology/mrbayes/files/mb_readline_312.patch37
-rw-r--r--sci-biology/mrbayes/metadata.xml18
-rw-r--r--sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild52
-rw-r--r--sci-biology/mrbayes/mrbayes-3.1.2-r2.ebuild62
5 files changed, 170 insertions, 0 deletions
diff --git a/sci-biology/mrbayes/Manifest b/sci-biology/mrbayes/Manifest
new file mode 100644
index 000000000000..d932da527753
--- /dev/null
+++ b/sci-biology/mrbayes/Manifest
@@ -0,0 +1 @@
+DIST mrbayes-3.1.2.tar.gz 545968 SHA256 c60253de1980c9f0a0eb684fffe7ba428fda7c39a3edcb6acf384b5e1443f2f4 SHA512 2fb0ee7224cbb69c1acf2ffb0c6c8974f63002cda4f39a626eadf80fad9cfc23861f8c03f5545970f3a81e02093d62b6a0549ab7d7f7080557e91e21b2c3ee14 WHIRLPOOL 45c9750a1e3e3ac85a1085bcaf8fc5c108b730a3dfa2f9e8d81cea8720bd6f02815c3145c19ee6c369a43f4565c2b234ec81cd5721672abded17186264de2e3f
diff --git a/sci-biology/mrbayes/files/mb_readline_312.patch b/sci-biology/mrbayes/files/mb_readline_312.patch
new file mode 100644
index 000000000000..2f8bab1e7665
--- /dev/null
+++ b/sci-biology/mrbayes/files/mb_readline_312.patch
@@ -0,0 +1,37 @@
+Index: Makefile
+===================================================================
+RCS file: /cvsroot/mrbayes/mrbayes/Makefile,v
+retrieving revision 3.23
+retrieving revision 3.24
+diff -U2 -r3.23 -r3.24
+--- Makefile 22 Dec 2005 16:13:06 -0000 3.23
++++ Makefile 3 Jan 2006 16:43:13 -0000 3.24
+@@ -50,4 +50,5 @@
+ ifeq ($(strip $(USEREADLINE)),yes)
+ CFLAGS += -DUSE_READLINE
++# CFLAGS += -DCOMPLETIONMATCHES
+ LIBS += -lncurses -lreadline
+ endif
+Index: bayes.c
+===================================================================
+RCS file: /cvsroot/mrbayes/mrbayes/bayes.c,v
+retrieving revision 3.39
+retrieving revision 3.40
+diff -U2 -r3.39 -r3.40
+--- bayes.c 23 Dec 2005 16:26:28 -0000 3.39
++++ bayes.c 3 Jan 2006 16:43:13 -0000 3.40
+@@ -382,9 +382,11 @@
+ char **readline_completion(const char *text, int start, int stop) {
+ char **matches = (char **) NULL;
+-
++
++#ifdef COMPLETIONMATCHES
+ if(start == 0)
+- matches = rl_completion_matches (text, command_generator);
++ matches = rl_completion_matches (text, command_generator);
++#endif
+
+- return (matches);
++ return (matches);
+ }
+ #endif
diff --git a/sci-biology/mrbayes/metadata.xml b/sci-biology/mrbayes/metadata.xml
new file mode 100644
index 000000000000..8a6a5b986dc7
--- /dev/null
+++ b/sci-biology/mrbayes/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+MrBayes is a program for the Bayesian estimation of phylogeny.
+Bayesian inference of phylogeny is based upon a quantity called the
+posterior probability distribution of trees, which is the probability of a
+tree conditioned on the observations. The conditioning is accomplished using
+Bayes's theorem. The posterior probability distribution of trees is
+impossible to calculate analytically; instead, MrBayes uses a simulation
+technique called Markov chain Monte Carlo (or MCMC) to approximate the
+posterior probabilities of trees.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">mrbayes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild b/sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild
new file mode 100644
index 000000000000..b4303b8f90b3
--- /dev/null
+++ b/sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Bayesian Inference of Phylogeny"
+HOMEPAGE="http://mrbayes.csit.fsu.edu/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug mpi readline"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+
+DEPEND="
+ sys-libs/ncurses
+ mpi? ( virtual/mpi )
+ readline? ( sys-libs/readline:0 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ use readline && epatch "${FILESDIR}"/mb_readline_312.patch
+ sed -e 's:-ggdb::g' -i Makefile || die
+}
+
+src_compile() {
+ local myconf mycc
+
+ if use mpi; then
+ mycc=mpicc
+ else
+ mycc=$(tc-getCC)
+ fi
+
+ use mpi && myconf="MPI=yes"
+ use readline || myconf="${myconf} USEREADLINE=no"
+ use debug && myconf="${myconf} DEBUG=yes"
+ emake \
+ OPTFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC=${mycc} \
+ ${myconf}
+}
+
+src_install() {
+ dobin mb
+ insinto /usr/share/${PN}
+ doins *.nex
+}
diff --git a/sci-biology/mrbayes/mrbayes-3.1.2-r2.ebuild b/sci-biology/mrbayes/mrbayes-3.1.2-r2.ebuild
new file mode 100644
index 000000000000..0c5a5015ecc7
--- /dev/null
+++ b/sci-biology/mrbayes/mrbayes-3.1.2-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Bayesian Inference of Phylogeny"
+HOMEPAGE="http://mrbayes.csit.fsu.edu/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="debug mpi readline"
+
+DEPEND="
+ sys-libs/ncurses
+ mpi? ( virtual/mpi )
+ readline? ( sys-libs/readline:0= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if use mpi; then
+ sed -e "s:MPI ?= no:MPI=yes:" -i Makefile || die "Patching MPI support."
+ fi
+ if ! use readline; then
+ sed -e "s:USEREADLINE ?= yes:USEREADLINE=no:" \
+ -i Makefile || die "Patching readline support."
+ else
+ # Only needed for OSX with an old (4.x) version of
+ # libreadline, but it doesn't hurt for other distributions.
+ epatch "${FILESDIR}"/mb_readline_312.patch
+ fi
+ sed -e 's:-ggdb::g' -i Makefile || die
+}
+
+src_compile() {
+ local myconf mycc
+
+ if use mpi; then
+ mycc=mpicc
+ else
+ mycc=$(tc-getCC)
+ fi
+
+ use mpi && myconf="MPI=yes"
+ use readline || myconf="${myconf} USEREADLINE=no"
+ use debug && myconf="${myconf} DEBUG=yes"
+ emake \
+ OPTFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC=${mycc} \
+ ${myconf}
+}
+
+src_install() {
+ dobin mb
+ insinto /usr/share/${PN}
+ doins *.nex
+}