summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-26 13:15:32 -0400
committerSam James <sam@gentoo.org>2024-06-27 03:57:33 +0100
commitea87da8046a907eff46319d0efc343c997df0bbe (patch)
treea8fec96d0d4098fc70152e19e7b17ca717334388 /sci-chemistry/chemex/chemex-2024.05.2-r1.ebuild
parentapp-text/lesspipe: avoid a false positive bash-completion QA warning (diff)
downloadgentoo-ea87da8046a907eff46319d0efc343c997df0bbe.tar.gz
gentoo-ea87da8046a907eff46319d0efc343c997df0bbe.tar.bz2
gentoo-ea87da8046a907eff46319d0efc343c997df0bbe.zip
sci-chemistry/chemex: fix mysterious overdependency on tomli
In upstream version 2024.02.09 some "refactoring" was done: https://github.com/gbouvignies/ChemEx/commit/97d6896836e4d5c23e0eff7b1dc1646e3f69ac9e It dropped support for python 3.10 and required the stdlib tomllib rather than trying tomli. And sure enough, when 2024.02.16 was added to ::gentoo, it excluded 3.10 support for this exact reason. But it didn't state why, and it didn't remove the out of date tomli dependency. Remove it now. Bug: https://bugs.gentoo.org/929756 Fixes: c5f2c621136bfc67183c410a60713763fd0f7bdf Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-chemistry/chemex/chemex-2024.05.2-r1.ebuild')
-rw-r--r--sci-chemistry/chemex/chemex-2024.05.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/chemex-2024.05.2-r1.ebuild b/sci-chemistry/chemex/chemex-2024.05.2-r1.ebuild
new file mode 100644
index 000000000000..87646d2c3045
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2024.05.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until tests are readded https://github.com/gbouvignies/ChemEx/issues/51
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/annotated-types-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-5.3.3[${PYTHON_USEDEP}]
+ >=dev-python/emcee-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.8.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.26.4[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.13.0[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}