summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ. Liu <zhixu.liu@gmail.com>2025-02-04 16:52:45 +0800
committerSam James <sam@gentoo.org>2025-02-04 16:53:23 +0000
commitbd6dcfd439e47120e713682d960864f07f265f5b (patch)
tree2af4cff0d662c617f7a79ce766226fed4f93b566 /sci-geosciences/grass
parentdev-dotnet/dotnet-sdk-bin: fix 9.0.102 SLOT (diff)
downloadgentoo-bd6dcfd439e47120e713682d960864f07f265f5b.tar.gz
gentoo-bd6dcfd439e47120e713682d960864f07f265f5b.tar.bz2
gentoo-bd6dcfd439e47120e713682d960864f07f265f5b.zip
sci-geosciences/grass: update openmp support check
Signed-off-by: Z. Liu <zhixu.liu@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/40434 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/grass-8.3.2-r1.ebuild8
-rw-r--r--sci-geosciences/grass/grass-8.4.0.ebuild8
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild8
3 files changed, 21 insertions, 3 deletions
diff --git a/sci-geosciences/grass/grass-8.3.2-r1.ebuild b/sci-geosciences/grass/grass-8.3.2-r1.ebuild
index 0871bb02df0d..9e070e7012a6 100644
--- a/sci-geosciences/grass/grass-8.3.2-r1.ebuild
+++ b/sci-geosciences/grass/grass-8.3.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -107,7 +107,13 @@ PATCHES=(
"${FILESDIR}/${PN}-flock.patch"
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
if use lapack; then
local mylapack=$(eselect lapack show)
if [[ -z "${mylapack/.*reference.*/}" ]] && \
diff --git a/sci-geosciences/grass/grass-8.4.0.ebuild b/sci-geosciences/grass/grass-8.4.0.ebuild
index 51d356ba10d0..de06e287f11f 100644
--- a/sci-geosciences/grass/grass-8.4.0.ebuild
+++ b/sci-geosciences/grass/grass-8.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -107,7 +107,13 @@ PATCHES=(
"${FILESDIR}/${PN}-flock.patch"
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
if use lapack; then
local mylapack=$(eselect lapack show)
if [[ -z "${mylapack/.*reference.*/}" ]] && \
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 558ef152545b..b35f6c4b8ae1 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -102,7 +102,13 @@ BDEPEND="
virtual/pkgconfig
X? ( dev-lang/swig )"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
if use lapack; then
local mylapack=$(eselect lapack show)
if [[ -z "${mylapack/.*reference.*/}" ]] && \