summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-16 19:15:41 -0400
committerSam James <sam@gentoo.org>2024-06-17 02:46:49 +0100
commit8a1f03945e92dac18f150996edae6f9c10911b97 (patch)
treeb97078598a6b866fe091bac51d0ac7ae715085f1 /sci-libs/cholmod
parentsys-apps/the_silver_searcher: fix compatibility with bash-completion 2.12 (diff)
downloadgentoo-8a1f03945e92dac18f150996edae6f9c10911b97.tar.gz
gentoo-8a1f03945e92dac18f150996edae6f9c10911b97.tar.bz2
gentoo-8a1f03945e92dac18f150996edae6f9c10911b97.zip
sci-libs/cholmod: fix missing autotools in src_prepare
Fixes regression caused by introducing a gentoo patch that modifies Makefile.am, but doesn't guarantee that it is regenerated in src_configure() -- or indeed that it has the necessary dependencies. Fixes: 6c0474cc8a08172cdc244af680edba8be5ada95b Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/cholmod')
-rw-r--r--sci-libs/cholmod/cholmod-3.0.13.ebuild6
-rw-r--r--sci-libs/cholmod/cholmod-3.0.14-r1.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/sci-libs/cholmod/cholmod-3.0.13.ebuild b/sci-libs/cholmod/cholmod-3.0.13.ebuild
index bc2fdd2aa62d..ff0f058dd29e 100644
--- a/sci-libs/cholmod/cholmod-3.0.13.ebuild
+++ b/sci-libs/cholmod/cholmod-3.0.13.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cuda toolchain-funcs
+inherit autotools cuda toolchain-funcs
DESCRIPTION="Sparse Cholesky factorization and update/downdate library"
HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
@@ -39,6 +39,8 @@ src_prepare() {
use cuda && cuda_src_prepare
default
+ # patch is modifying Makefile.am
+ eautoreconf
}
src_configure() {
diff --git a/sci-libs/cholmod/cholmod-3.0.14-r1.ebuild b/sci-libs/cholmod/cholmod-3.0.14-r1.ebuild
index 669494c2ea85..39f7dc95b12b 100644
--- a/sci-libs/cholmod/cholmod-3.0.14-r1.ebuild
+++ b/sci-libs/cholmod/cholmod-3.0.14-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cuda toolchain-funcs
+inherit autotools cuda toolchain-funcs
DESCRIPTION="Sparse Cholesky factorization and update/downdate library"
HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
@@ -39,6 +39,8 @@ src_prepare() {
use cuda && cuda_src_prepare
default
+ # patch is modifying Makefile.am
+ eautoreconf
}
src_configure() {