summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-11-13 21:23:11 -0500
committerMichael Orlitzky <mjo@gentoo.org>2023-11-13 21:24:30 -0500
commitd5cad95f6c02a29cf004130f715d994b66a4b07a (patch)
tree2d7cf02055d73eb403186a7b90588564bf59959b /sci-mathematics
parentdev-libs/vala-common: Version bump to 0.56.14 (diff)
downloadgentoo-d5cad95f6c02a29cf004130f715d994b66a4b07a.tar.gz
gentoo-d5cad95f6c02a29cf004130f715d994b66a4b07a.tar.bz2
gentoo-d5cad95f6c02a29cf004130f715d994b66a4b07a.zip
sci-mathematics/polymake: re-enable the test suite
After adding another patch, the test suite once again passes for me (it hasn't for a few versions, but it did a long time ago). Let's enable it and get some feedback. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/polymake/files/polymake-4.11-barycentric-subdiv.patch23
-rw-r--r--sci-mathematics/polymake/polymake-4.11.ebuild10
2 files changed, 27 insertions, 6 deletions
diff --git a/sci-mathematics/polymake/files/polymake-4.11-barycentric-subdiv.patch b/sci-mathematics/polymake/files/polymake-4.11-barycentric-subdiv.patch
new file mode 100644
index 000000000000..2f58b0f76299
--- /dev/null
+++ b/sci-mathematics/polymake/files/polymake-4.11-barycentric-subdiv.patch
@@ -0,0 +1,23 @@
+commit d55dc6bd7f2da9245884f86706cb96e2d11fa83a
+Author: Benjamin Lorenz <lorenz@math.tu-berlin.de>
+Date: Tue Nov 7 16:49:33 2023 +0100
+
+ barycentric_subdivision: dont call back on empty strings
+
+ thanks jamesjer
+
+ @Jenkins: merge
+
+diff --git a/apps/topaz/src/barycentric_subdivision.cc b/apps/topaz/src/barycentric_subdivision.cc
+index 753afb4040..e2d4130bc3 100644
+--- a/apps/topaz/src/barycentric_subdivision.cc
++++ b/apps/topaz/src/barycentric_subdivision.cc
+@@ -139,7 +139,7 @@ bs_data2Object(const bool realize,
+ else
+ desc << k << "th ";
+ desc << "barycentric subdivision of " << description;
+- if (description.back() != '\n')
++ if (description.empty() || description.back() != '\n')
+ desc << endl;
+ p_out.set_description() << desc.str();
+ return p_out;
diff --git a/sci-mathematics/polymake/polymake-4.11.ebuild b/sci-mathematics/polymake/polymake-4.11.ebuild
index 56790dcb5cc9..5feccaae668e 100644
--- a/sci-mathematics/polymake/polymake-4.11.ebuild
+++ b/sci-mathematics/polymake/polymake-4.11.ebuild
@@ -53,12 +53,10 @@ RDEPEND="${DEPEND}
dev-perl/XML-SAX
dev-perl/XML-Writer"
-# Tests observed failing after upgrade to polymake-4.5. No idea if they
-# worked prior to that. Someone who actually understands polymake will
-# have to get these working (at least briefly) before we re-enable them.
-RESTRICT=test
-
-PATCHES=( "${FILESDIR}/${P}-singular-sat.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-singular-sat.patch"
+ "${FILESDIR}/${P}-barycentric-subdiv.patch"
+)
src_configure() {
# Without this, the build system tries to use "the highest possible"