summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2020-05-03 21:51:04 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-05-20 14:37:27 +0200
commit18066a823662ba9f21093ba36f978dd72aa007c1 (patch)
treef5de4b7e027522e3c1b54d7aa810f0fabb28a7f3 /sci-physics/geant-vmc/geant-vmc-9999.ebuild
parentsci-physics/vgm: Add amadio as maintainer (diff)
downloadgentoo-18066a823662ba9f21093ba36f978dd72aa007c1.tar.gz
gentoo-18066a823662ba9f21093ba36f978dd72aa007c1.tar.bz2
gentoo-18066a823662ba9f21093ba36f978dd72aa007c1.zip
sci-physics/geant-vmc: Version bump to 4.5.1_p1
New version is now compatible with sci-physics/vmc. Closes: https://github.com/gentoo/gentoo/pull/15631 Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --force Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/geant-vmc/geant-vmc-9999.ebuild')
-rw-r--r--sci-physics/geant-vmc/geant-vmc-9999.ebuild43
1 files changed, 23 insertions, 20 deletions
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
index 9c27c2d98efa..b28eff16cc8b 100644
--- a/sci-physics/geant-vmc/geant-vmc-9999.ebuild
+++ b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,26 +8,35 @@ inherit cmake
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/vmc-project/geant4_vmc.git"
+ KEYWORDS=""
else
- DOWN_PV=$(ver_cut 2-)
- SRC_URI="http://root.cern.ch/download/vmc/geant4_vmc.${DOWN_PV}.tar.gz"
- SOURCE_PV=$(ver_rs 1- . ${DOWN_PV})
- S="${WORKDIR}/geant4_vmc.${SOURCE_PV}"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ MY_PV=$(ver_rs 1-2 - $(ver_cut 2-))
+ SRC_URI="https://github.com/vmc-project/geant4-vmc/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/geant4_vmc-${MY_PV}"
+ KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
HOMEPAGE="http://root.cern.ch/root/vmc/VirtualMC.html"
-LICENSE="GPL-2"
+LICENSE="GPL-3"
SLOT="4"
-IUSE="doc examples geant3 +g4root +mtroot vgm test"
+IUSE="+c++11 c++14 c++17 doc examples geant3 +g4root +mtroot rootvmc vgm test"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
-# sci-physics/root[c++11] required to match sci-physics/geant flags.
RDEPEND="
- >=sci-physics/geant-4.10.03:=[opengl,geant3?]
- sci-physics/root:=[c++11,vmc]
- vgm? ( >=sci-physics/vgm-4.4:= )"
+ rootvmc? (
+ >=sci-physics/root-6.18:=[vmc]
+ !!sci-physics/vmc
+ )
+ !rootvmc? (
+ >=sci-physics/root-6.18:=[-vmc]
+ sci-physics/vmc:=[c++11?,c++14?,c++17?]
+ )
+ >=sci-physics/geant-4.10.6[c++11?,c++14?,c++17?,opengl,geant3?]
+ >=sci-physics/root-6.18:=[c++11?,c++14?,c++17?]
+ vgm? ( >=sci-physics/vgm-4.8:=[c++11?,c++14?,c++17?] )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
RESTRICT="
@@ -38,10 +47,7 @@ RESTRICT="
!test? ( test )
!vgm? ( test )"
-DOCS=(
- history
- README.md
-)
+DOCS=(history README.md)
src_configure() {
local mycmakeargs=(
@@ -74,12 +80,9 @@ src_compile() {
}
src_test() {
- # Required by sci-physics/root for pointer validity checking,
- # see e.g. https://sft.its.cern.ch/jira/browse/ROOT-8146 .
- addwrite /dev/random
cd examples || die
./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
- ./test_suite_exe.sh -debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
}
src_install() {