summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-08-02 16:07:33 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-08-05 17:28:35 +0200
commit9e0ab0d8ef866b1aa2714ed8a45f37c27ebed7d1 (patch)
tree748fec1e65c68c959af92a8df567d6683b111136 /sci-physics/root/root-9999.ebuild
parentdev-libs/intel-neo: bump to 19.30.13641 (diff)
downloadgentoo-9e0ab0d8ef866b1aa2714ed8a45f37c27ebed7d1.tar.gz
gentoo-9e0ab0d8ef866b1aa2714ed8a45f37c27ebed7d1.tar.bz2
gentoo-9e0ab0d8ef866b1aa2714ed8a45f37c27ebed7d1.zip
sci-physics/root: add nosplash USE flag
This disables ROOT's splash screen by default. Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/root/root-9999.ebuild')
-rw-r--r--sci-physics/root/root-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index d300c32a9370..dbe4236df64c 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -17,9 +17,9 @@ HOMEPAGE="https://root.cern"
IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
fits fftw fortran +gdml graphviz +gsl http libcxx +minuit mysql
- odbc +opengl oracle postgres prefix pythia6 pythia8 +python qt5 R
- +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc vmc
- +xml xrootd"
+ nosplash odbc +opengl oracle postgres prefix pythia6 pythia8
+ +python qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva
+ +unuran vc vmc +xml xrootd"
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
@@ -138,6 +138,10 @@ src_prepare() {
# CSS should use local images
sed -i -e 's,http://.*/,,' etc/html/ROOT.css || die "html sed failed"
+ if use nosplash; then
+ sed -i -e '/bool gNoLogo/s@false@true@' rootx/src/rootx.cxx
+ fi
+
hprefixify core/clingutils/CMakeLists.txt
}