summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-10 16:45:09 +0100
committerSam James <sam@gentoo.org>2022-07-10 16:45:28 +0100
commite906be651e077ccff5da8b0291a731cf830197a8 (patch)
tree92ef121b62268454eb7a14de4c551cba158b0695 /sys-apps/clrngd
parentapp-crypt/ckpass: EAPI 8 (diff)
downloadgentoo-e906be651e077ccff5da8b0291a731cf830197a8.tar.gz
gentoo-e906be651e077ccff5da8b0291a731cf830197a8.tar.bz2
gentoo-e906be651e077ccff5da8b0291a731cf830197a8.zip
sys-apps/clrngd: EAPI 8; fix implicit func. decl
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/clrngd')
-rw-r--r--sys-apps/clrngd/clrngd-1.0.3-r1.ebuild (renamed from sys-apps/clrngd/clrngd-1.0.3.ebuild)16
-rw-r--r--sys-apps/clrngd/files/clrngd-1.0.3-implicit-func-declaration.patch27
2 files changed, 41 insertions, 2 deletions
diff --git a/sys-apps/clrngd/clrngd-1.0.3.ebuild b/sys-apps/clrngd/clrngd-1.0.3-r1.ebuild
index 6cc2a27825b2..086359cbc77f 100644
--- a/sys-apps/clrngd/clrngd-1.0.3.ebuild
+++ b/sys-apps/clrngd/clrngd-1.0.3-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit autotools
DESCRIPTION="Clock randomness gathering daemon"
HOMEPAGE="http://echelon.pl/pubs/"
@@ -11,6 +13,16 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-implicit-func-declaration.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
src_configure() {
econf --bindir="${EPREFIX}"/usr/sbin
}
diff --git a/sys-apps/clrngd/files/clrngd-1.0.3-implicit-func-declaration.patch b/sys-apps/clrngd/files/clrngd-1.0.3-implicit-func-declaration.patch
new file mode 100644
index 000000000000..075866ec8044
--- /dev/null
+++ b/sys-apps/clrngd/files/clrngd-1.0.3-implicit-func-declaration.patch
@@ -0,0 +1,27 @@
+--- a/clrngd.c
++++ b/clrngd.c
+@@ -14,6 +14,13 @@
+ #include <sys/time.h>
+ #include <stdio.h>
+ #include <string.h>
++
++#ifdef HAVE_STROPT_H
++#include <stropts.h>
++#else
++#include <sys/ioctl.h>
++#endif
++
+ #include <linux/types.h>
+ #include <linux/random.h>
+ #include <errno.h>
+--- a/configure.in
++++ b/configure.in
+@@ -18,7 +18,7 @@ dnl Checks for libraries.
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(unistd.h sys/param.h sys/time.h time.h sys/mkdev.h sys/sysmacros.h string.h memory.h fcntl.h dirent.h sys/ndir.h ndir.h alloca.h locale.h )
++AC_CHECK_HEADERS(unistd.h sys/param.h sys/time.h time.h sys/mkdev.h sys/sysmacros.h string.h memory.h fcntl.h dirent.h sys/ndir.h ndir.h alloca.h locale.h stropts.h)
+
+ jm_CHECK_TYPE_STRUCT_UTIMBUF
+ AC_HEADER_MAJOR