summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-24 14:54:42 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-24 14:54:58 +0200
commit4e0151d9ff78bcb9d5b3ccf9b9bfb8217e60be0f (patch)
tree60f8c4b4bcfdbe6401e0f5236aac65f20eeafc5b /sys-apps/fwupd/files
parentsys-apps/fwupdate: Initial commit. (diff)
downloadgentoo-4e0151d9ff78bcb9d5b3ccf9b9bfb8217e60be0f.tar.gz
gentoo-4e0151d9ff78bcb9d5b3ccf9b9bfb8217e60be0f.tar.bz2
gentoo-4e0151d9ff78bcb9d5b3ccf9b9bfb8217e60be0f.zip
sys-apps/fwupd: Initial commit.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-apps/fwupd/files')
-rw-r--r--sys-apps/fwupd/files/fwupd-0.9-polkit_its_files.patch65
-rw-r--r--sys-apps/fwupd/files/fwupd-0.9.2-no_systemd.patch77
2 files changed, 142 insertions, 0 deletions
diff --git a/sys-apps/fwupd/files/fwupd-0.9-polkit_its_files.patch b/sys-apps/fwupd/files/fwupd-0.9-polkit_its_files.patch
new file mode 100644
index 000000000000..999df1cba252
--- /dev/null
+++ b/sys-apps/fwupd/files/fwupd-0.9-polkit_its_files.patch
@@ -0,0 +1,65 @@
+From 797e5672e64acd4f90cd52afca3bb192b28b4636 Mon Sep 17 00:00:00 2001
+From: Julian Liu <liu.julian@gmail.com>
+Date: Fri, 28 Apr 2017 18:09:20 +0800
+Subject: [PATCH] Add polkit's ITS files as Ubuntu doesn't not ship with it.
+
+Call msgfmt with custom_target for now as data_dir kargs for i18n.merge_file() not merged into master yet.
+(https://github.com/mesonbuild/meson/issues/1565)
+---
+ its/polkit.its | 8 ++++++++
+ its/polkit.loc | 6 ++++++
+ policy/meson.build | 12 ++++++++----
+ 3 files changed, 22 insertions(+), 4 deletions(-)
+ create mode 100644 its/polkit.its
+ create mode 100644 its/polkit.loc
+
+diff --git a/its/polkit.its b/its/polkit.its
+new file mode 100644
+index 0000000..1c37e6b
+--- /dev/null
++++ b/its/polkit.its
+@@ -0,0 +1,8 @@
++<?xml version="1.0"?>
++<its:rules xmlns:its="http://www.w3.org/2005/11/its"
++ version="2.0">
++ <its:translateRule selector="//*" translate="no"/>
++ <its:translateRule selector="//action/description |
++ //action/message"
++ translate="yes"/>
++</its:rules>
+diff --git a/its/polkit.loc b/its/polkit.loc
+new file mode 100644
+index 0000000..c7427ec
+--- /dev/null
++++ b/its/polkit.loc
+@@ -0,0 +1,6 @@
++<?xml version="1.0"?>
++<locatingRules>
++ <locatingRule name="polkit policy" pattern="*.policy">
++ <documentRule localName="policyconfig" target="polkit.its"/>
++ </locatingRule>
++</locatingRules>
+diff --git a/policy/meson.build b/policy/meson.build
+index def8976..41da2db 100644
+--- a/policy/meson.build
++++ b/policy/meson.build
+@@ -1,11 +1,15 @@
+ install_data('org.freedesktop.fwupd.rules',
+ install_dir : 'share/polkit-1/rules.d')
+
+-i18n.merge_file(
+- input: 'org.freedesktop.fwupd.policy.in',
++envbin = find_program('env')
++gettext_data_dir = 'GETTEXTDATADIRS=' + meson.source_root()
++custom_target('org.freedesktop.fwupd.policy',
+ output: 'org.freedesktop.fwupd.policy',
+- type: 'xml',
+- po_dir: join_paths(meson.source_root(), 'po'),
++ input: 'org.freedesktop.fwupd.policy.in',
++ command: [envbin, gettext_data_dir, 'msgfmt', '--xml',
++ '--template', '@INPUT@',
++ '-d', join_paths(meson.source_root(), 'po'),
++ '-o', '@OUTPUT@'],
+ install: true,
+ install_dir: join_paths(get_option('datadir'), 'polkit-1', 'actions')
+ )
diff --git a/sys-apps/fwupd/files/fwupd-0.9.2-no_systemd.patch b/sys-apps/fwupd/files/fwupd-0.9.2-no_systemd.patch
new file mode 100644
index 000000000000..354b5e5800e4
--- /dev/null
+++ b/sys-apps/fwupd/files/fwupd-0.9.2-no_systemd.patch
@@ -0,0 +1,77 @@
+--- fwupd-0.9.2/data/meson.build
++++ fwupd-0.9.2/data/meson.build
+@@ -38,20 +38,22 @@
+ 'system-services'),
+ )
+
+-# replace @bindir@
+-configure_file(
+- input : 'fwupd-offline-update.service.in',
+- output : 'fwupd-offline-update.service',
+- configuration : con2,
+- install: true,
+- install_dir: systemd.get_pkgconfig_variable('systemdsystemunitdir'),
+-)
++if get_option('with-systemd') and systemd.found()
++ # replace @bindir@
++ configure_file(
++ input : 'fwupd-offline-update.service.in',
++ output : 'fwupd-offline-update.service',
++ configuration : con2,
++ install: true,
++ install_dir: systemd.get_pkgconfig_variable('systemdsystemunitdir'),
++ )
+
+-# replace @localstatedir@ and @bootdir@
+-configure_file(
+- input : 'fwupd.service.in',
+- output : 'fwupd.service',
+- configuration : con2,
+- install: true,
+- install_dir: systemd.get_pkgconfig_variable('systemdsystemunitdir'),
+-)
++ # replace @localstatedir@ and @bootdir@
++ configure_file(
++ input : 'fwupd.service.in',
++ output : 'fwupd.service',
++ configuration : con2,
++ install: true,
++ install_dir: systemd.get_pkgconfig_variable('systemdsystemunitdir'),
++ )
++endif
+--- fwupd-0.9.2/meson.build
++++ fwupd-0.9.2/meson.build
+@@ -127,13 +127,17 @@
+ gpgme = cc.find_library('gpgme')
+ gpgerror = cc.find_library('libgpg-error')
+ libm = cc.find_library('libm', required: false)
+-systemd = dependency('systemd')
+ udev = dependency('udev')
+
+ if valgrind.found()
+ conf.set('HAVE_VALGRIND', '1')
+ endif
+
++if get_option('with-systemd')
++ systemd = dependency('systemd')
++ conf.set('HAVE_SYSTEMD', '1')
++endif
++
+ if get_option('enable-colorhug')
+ colorhug = dependency('colorhug', version : '>= 1.2.12')
+ conf.set('HAVE_COLORHUG', '1')
+@@ -220,4 +224,6 @@
+ message('git not found, you will not be able to run `ninja dist`')
+ endif
+
+-meson.add_install_script('meson_post_install.sh', systemd.get_pkgconfig_variable('systemdsystemunitdir'), localstatedir)
++if get_option('with-systemd') and systemd.found()
++ meson.add_install_script('meson_post_install.sh', systemd.get_pkgconfig_variable('systemdsystemunitdir'), localstatedir)
++endif
+--- fwupd-0.9.2/meson_options.txt
++++ fwupd-0.9.2/meson_options.txt
+@@ -5,3 +5,4 @@
+ option('enable-dell', type : 'boolean', value : true, description : 'enable Dell-specific support')
+ option('enable-thunderbolt', type : 'boolean', value : true, description : 'enable Thunderbolt support')
+ option('with-bootdir', type : 'string', value : '/boot/efi', description : 'Directory for EFI system partition')
++option('with-systemd', type : 'boolean', value : true, description : 'Install systemd unit files')