summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-03 08:19:43 +0000
committerSam James <sam@gentoo.org>2023-12-03 08:19:43 +0000
commitd9a4afa8cf01a85dde9715eeaea2e1d0a1b19f83 (patch)
tree7419bf02ce1c3bf13f6166c3c030701eaf4cd987 /sys-apps/moar
parentdev-lang/perl: perl-cross-1.5.1 -> perl-cross-1.5.2 for 5.38.2 (diff)
downloadgentoo-d9a4afa8cf01a85dde9715eeaea2e1d0a1b19f83.tar.gz
gentoo-d9a4afa8cf01a85dde9715eeaea2e1d0a1b19f83.tar.bz2
gentoo-d9a4afa8cf01a85dde9715eeaea2e1d0a1b19f83.zip
sys-apps/moar: add 1.18.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.18.5.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 00b98e236025..56592e0131f4 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -2,3 +2,5 @@ DIST moar-1.18.3-deps.tar.xz 4893264 BLAKE2B 48ac9d4992c2f6d1aa0f9160bde87bd19d6
DIST moar-1.18.3.tar.gz 2784912 BLAKE2B 8ad06cfb0c21225e5b949d39adbadadef98e4e4292432cd3e6533240afa416118fb9a9d21b06d6bdf85a6f2a19b90f09c3e298db24fec755a168423e85dc9c64 SHA512 81e54889fa0a12d127abc5596fd820d5adc5f5162adedd7125cf9e8cbd0cb0dc75c5570a1504b2c68e063880e77df4299d7830a44479c6690f6ba48ec97ea4ac
DIST moar-1.18.4-deps.tar.xz 4893264 BLAKE2B 48ac9d4992c2f6d1aa0f9160bde87bd19d66acfe912753645c9dbb6e5bc007eb68caf1fff53bae84b03e4a6607858717666b1527bf8d0080b0aca6dbb37a894e SHA512 bf141777d4fee5c14e76130671862f255675da3c628c21cb892d53a469a0872d4c7f47699c16c50728df76ba4d9e467e9b8744a322c1acc8d0151f9eb5987b66
DIST moar-1.18.4.tar.gz 2785962 BLAKE2B 9fdce78371e99a2e8b6be79ee6b16e880a670ace989013898ea23a84b9a8701a7832519108c03503e6a021fb34b518cc57642b08f2ae404a182cfe58157fe3ee SHA512 4ce60f3a57241058fce83a1663e6aea6f3eb485a80a433243d76e522ee2cdd8bbec94913820d50949610f923d975cfa2588cf11e7824c3cf0f3beb38988a2a00
+DIST moar-1.18.5-deps.tar.xz 4893264 BLAKE2B 48ac9d4992c2f6d1aa0f9160bde87bd19d66acfe912753645c9dbb6e5bc007eb68caf1fff53bae84b03e4a6607858717666b1527bf8d0080b0aca6dbb37a894e SHA512 bf141777d4fee5c14e76130671862f255675da3c628c21cb892d53a469a0872d4c7f47699c16c50728df76ba4d9e467e9b8744a322c1acc8d0151f9eb5987b66
+DIST moar-1.18.5.tar.gz 2786493 BLAKE2B dc8e47fd59cb485d7b105428053015221b280753838d5a21c140df49b51aebea7befa14ba4549f89019956c1df2cf9bf5ffeab458fa99f483f353dcb63100bd6 SHA512 c7efc790d6a8b0867a0e8c5734b95e03b6deed3627f9278b7a7e8086cf4313322d87ac98e34ec1777f9a01b0dddac894737d09c1c20aaed1fa2b2b47a370d59d
diff --git a/sys-apps/moar/moar-1.18.5.ebuild b/sys-apps/moar/moar-1.18.5.ebuild
new file mode 100644
index 000000000000..25abd2aac1ff
--- /dev/null
+++ b/sys-apps/moar/moar-1.18.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}