summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-01-01 20:00:01 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-01-01 20:07:36 +0100
commit1d20ff6ca2a746f96b668c1b1d5c22ee5b742965 (patch)
tree00b30173844ed965826ae7712acb5c94d48e5e73 /sys-apps
parentsys-apps/darwin-miscutils: version bump to High Sierra version (diff)
downloadgentoo-1d20ff6ca2a746f96b668c1b1d5c22ee5b742965.tar.gz
gentoo-1d20ff6ca2a746f96b668c1b1d5c22ee5b742965.tar.bz2
gentoo-1d20ff6ca2a746f96b668c1b1d5c22ee5b742965.zip
sys-apps/microcode-ctl: Rev bump for EAPI bump
HOMEPAGE and SRC_URI changed from Fedorahosted pagure.io. [Bug 618058] Closes: https://bugs.gentoo.org/618058 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.28-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.28-r2.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.28-r2.ebuild
new file mode 100644
index 000000000000..4ca58a106615
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.28-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs versionator
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel processor microcode update utility"
+HOMEPAGE="https://pagure.io/microcode_ctl"
+SRC_URI="https://releases.pagure.org/${PN/-/_}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="selinux"
+
+DEPEND=""
+RDEPEND=">=sys-firmware/intel-microcode-20090330[monolithic(+)]
+ selinux? ( sec-policy/selinux-cpucontrol )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dosbin microcode_ctl
+ doman microcode_ctl.8
+ dodoc Changelog README
+}
+
+pkg_preinst() {
+ local _v
+ for _v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 1.28-r1 ${_v}; then
+ # This is an upgrade
+ elog "The init scripts have been removed as they are unsafe. If you want to update"
+ elog "the microcode in your system, please use an initramfs. See bug #528712#41 for"
+ elog "details (and bug #557278 for genkernel users)."
+ fi
+
+ # Show this elog only once
+ break
+ done
+}