summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-24 23:45:59 +0100
committerSam James <sam@gentoo.org>2022-05-24 23:45:59 +0100
commitc5757bbf5bb9a484cd883b2e7c71b99b586a6dca (patch)
tree20418b5b7311055653b1fc0531d42d06d8b82f9a /sys-apps
parentsys-apps/acl: filter-flags for F_S=3 (diff)
downloadgentoo-c5757bbf5bb9a484cd883b2e7c71b99b586a6dca.tar.gz
gentoo-c5757bbf5bb9a484cd883b2e7c71b99b586a6dca.tar.bz2
gentoo-c5757bbf5bb9a484cd883b2e7c71b99b586a6dca.zip
sys-apps/systemd: set QA_PKGCONFIG_VERSION
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/systemd-251.1.ebuild2
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-apps/systemd/systemd-251.1.ebuild b/sys-apps/systemd/systemd-251.1.ebuild
index 9381570446ab..285ae73ff43f 100644
--- a/sys-apps/systemd/systemd-251.1.ebuild
+++ b/sys-apps/systemd/systemd-251.1.ebuild
@@ -7,6 +7,8 @@ PYTHON_COMPAT=( python3_{8..10} )
# Avoid QA warnings
TMPFILES_OPTIONAL=1
+QA_PKGCONFIG_VERSION=$(ver_cut 1)
+
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
inherit git-r3
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index efeb0fe26832..06de6c48675c 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -7,6 +7,8 @@ PYTHON_COMPAT=( python3_{8..10} )
# Avoid QA warnings
TMPFILES_OPTIONAL=1
+QA_PKGCONFIG_VERSION=$(ver_cut 1)
+
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
inherit git-r3