summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2021-12-21 12:49:28 -0600
committerJohn Helmert III <ajak@gentoo.org>2021-12-22 13:55:43 -0600
commitb41c080c3595a1cd80bad72222887866b8372f0c (patch)
tree6da688d6231871424c6808ed5c1b9a1b590e8026 /sys-boot
parentdev-python/python-glanceclient: Remove old (diff)
downloadgentoo-b41c080c3595a1cd80bad72222887866b8372f0c.tar.gz
gentoo-b41c080c3595a1cd80bad72222887866b8372f0c.tar.bz2
gentoo-b41c080c3595a1cd80bad72222887866b8372f0c.zip
sys-boot/tboot: Don't call ar directly
Closes: https://bugs.gentoo.org/829745 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23456 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch12
-rw-r--r--sys-boot/tboot/files/tboot-1.10.3-dont-call-toolchain-directly.patch24
-rw-r--r--sys-boot/tboot/tboot-1.10.3.ebuild2
3 files changed, 25 insertions, 13 deletions
diff --git a/sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch b/sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch
deleted file mode 100644
index 83adeda6d5ac..000000000000
--- a/sys-boot/tboot/files/tboot-1.10.3-dont-call-strip-directly.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r 5a30b6b09e77 tboot/Makefile
---- a/tboot/Makefile Fri Dec 10 15:35:42 2021 +0100
-+++ b/tboot/Makefile Mon Dec 20 13:06:09 2021 -0600
-@@ -34,7 +34,7 @@
- TARGET_LDS := $(CURDIR)/common/tboot.lds
-
- $(TARGET).strip : $(TARGET)
-- strip $< -o $@
-+ $(STRIP) $< -o $@
-
- $(TARGET).gz : $(TARGET).strip
- gzip -n -f -9 < $< > $@
diff --git a/sys-boot/tboot/files/tboot-1.10.3-dont-call-toolchain-directly.patch b/sys-boot/tboot/files/tboot-1.10.3-dont-call-toolchain-directly.patch
new file mode 100644
index 000000000000..29840e9113e4
--- /dev/null
+++ b/sys-boot/tboot/files/tboot-1.10.3-dont-call-toolchain-directly.patch
@@ -0,0 +1,24 @@
+diff -r 5a30b6b09e77 safestringlib/makefile
+--- a/safestringlib/makefile Fri Dec 10 15:35:42 2021 +0100
++++ b/safestringlib/makefile Tue Dec 21 12:40:01 2021 -0600
+@@ -29,7 +29,7 @@
+ $(CC) $(LDFLAGS) -c -o $@ $< $(CFLAGS)
+
+ libsafestring.a: $(OBJ)
+- ar rcs $@ $^
++ $(AR) rcs $@ $^
+
+
+ _TESTFUNCS = Safe_String_UnitTestMain.c test_strcmp_s.c test_strnlen_s.c test_memcmp16_s.c test_strcpyfldin_s.c test_strnterminate_s.c test_memcmp32_s.c test_strcpyfldout_s.c test_strpbrk_s.c test_memcmp_s.c test_strcpyfld_s.c test_strprefix_s.c test_memcpy16_s.c test_strcpy_s.c test_strremovews_s.c test_memcpy32_s.c test_strcspn_s.c test_strspn_s.c test_memcpy_s.c test_strfirstchar_s.c test_strstr_s.c test_memmove16_s.c test_strfirstdiff_s.c test_strtok_s.c test_memmove32_s.c test_strfirstsame_s.c test_strtolowercase_s.c test_memmove_s.c test_strisalphanumeric_s.c test_strtouppercase_s.c test_memset16_s.c test_strisascii_s.c test_strzero_s.c test_memset32_s.c test_strisdigit_s.c test_wcpcpy_s.c test_memset_s.c test_strishex_s.c test_wcscat_s.c test_memzero16_s.c test_strislowercase_s.c test_wcscpy_s.c test_memzero32_s.c test_strismixed_s.c test_wcsncat_s.c test_memzero_s.c test_strispassword_s.c test_wcsncpy_s.c test_strisuppercase_s.c test_wcsnlen_s.c test_stpcpy_s.c test_strlastchar_s.c test_wmemcmp_s.c test_stpncpy_s.c test_strlastdiff_s.c test_wmemcpy_s.c test_strcasecmp_s.c test_strlastsame_s.c test_wmemmove_s.c test_strcasestr_s.c test_strljustify_s.c test_wmemset_s.c test_strcat_s.c test_strncat_s.c test_strcmpfld_s.c test_strncpy_s.c
+diff -r 5a30b6b09e77 tboot/Makefile
+--- a/tboot/Makefile Fri Dec 10 15:35:42 2021 +0100
++++ b/tboot/Makefile Tue Dec 21 12:40:01 2021 -0600
+@@ -34,7 +34,7 @@
+ TARGET_LDS := $(CURDIR)/common/tboot.lds
+
+ $(TARGET).strip : $(TARGET)
+- strip $< -o $@
++ $(STRIP) $< -o $@
+
+ $(TARGET).gz : $(TARGET).strip
+ gzip -n -f -9 < $< > $@
diff --git a/sys-boot/tboot/tboot-1.10.3.ebuild b/sys-boot/tboot/tboot-1.10.3.ebuild
index 1c4693a6e37b..cdb682a949ff 100644
--- a/sys-boot/tboot/tboot-1.10.3.ebuild
+++ b/sys-boot/tboot/tboot-1.10.3.ebuild
@@ -26,7 +26,7 @@ RDEPEND="${DEPEND}
DOCS=( README.md COPYING CHANGELOG )
PATCHES=( "${FILESDIR}/${PN}-1.10.3-disable-Werror.patch"
"${FILESDIR}/${PN}-1.10.3-disable-strip.patch"
- "${FILESDIR}/${PN}-1.10.3-dont-call-strip-directly.patch" )
+ "${FILESDIR}/${PN}-1.10.3-dont-call-toolchain-directly.patch" )
src_configure() {
tc-export AS LD CC CPP AR RANLIB NM OBJCOPY OBJDUMP STRIP