summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-01-06 11:51:18 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-01-06 11:51:18 +0000
commit1f497cfc6bbad7c1ba32072af7f06254d29b01d2 (patch)
treed51a5b4e6fb8c2813a712e49b73fbefa5abffc55 /sys-devel
parentsys-devel/binutils: Add conditional patch to fix ld.bfd prefix handling (diff)
downloadgentoo-1f497cfc6bbad7c1ba32072af7f06254d29b01d2.tar.gz
gentoo-1f497cfc6bbad7c1ba32072af7f06254d29b01d2.tar.bz2
gentoo-1f497cfc6bbad7c1ba32072af7f06254d29b01d2.zip
sys-devel/binutils: Resync 2.41-r4 from 2.41-r3
My earlier fix missed changes that been made since I wrote it. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.41-r4.ebuild15
1 files changed, 3 insertions, 12 deletions
diff --git a/sys-devel/binutils/binutils-2.41-r4.ebuild b/sys-devel/binutils/binutils-2.41-r4.ebuild
index 0fe91dacf35e..d57525849982 100644
--- a/sys-devel/binutils/binutils-2.41-r4.ebuild
+++ b/sys-devel/binutils/binutils-2.41-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -184,12 +184,7 @@ src_configure() {
use cet && filter-flags -mindirect-branch -mindirect-branch=*
use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
- # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
- # https://github.com/gentoo/gentoo/pull/28355
- # mold needs this too but right now tc-ld-is-mold is also not available
- if tc-ld-is-lld; then
- append-ldflags -Wl,--undefined-version
- fi
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
local x
echo
@@ -357,11 +352,7 @@ src_compile() {
cd "${MY_BUILDDIR}" || die
# see Note [tooldir hack for ldscripts]
- # see linker prefix patch
- emake \
- tooldir="${EPREFIX}${TOOLPATH}" \
- gentoo_prefix=$(usex prefix-guest "${EPREFIX}"/usr /usr) \
- all
+ emake tooldir="${EPREFIX}${TOOLPATH}" all
# only build info pages if the user wants them
if use doc ; then