summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-12 10:17:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-12 10:17:58 +0100
commit307a3dd56e1ff7ae14aa7102c241df6243a95c54 (patch)
tree531d0cabacd5d250a4a4846ffc71a26e71da6770 /sys-devel
parentsys-devel/clang-common: Bump to 14.0.0_rc4 (diff)
downloadgentoo-307a3dd56e1ff7ae14aa7102c241df6243a95c54.tar.gz
gentoo-307a3dd56e1ff7ae14aa7102c241df6243a95c54.tar.bz2
gentoo-307a3dd56e1ff7ae14aa7102c241df6243a95c54.zip
sys-devel/clang-runtime: Bump to 14.0.0_rc4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.0_rc4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.0_rc4.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.0_rc4.ebuild
new file mode 100644
index 000000000000..e02d928d2be4
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.0_rc4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"