summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2017-09-18 20:35:57 +0900
committerAlexis Ballier <aballier@gentoo.org>2017-10-02 10:56:07 +0200
commitc4e6110acc43e8b8148cfeafa9c441ecb0c2a9e0 (patch)
tree4f460d123f56875adfa04b36003666278d4b114c /sys-freebsd/freebsd-lib/files
parenteclass/freebsd.eclass: use install.sh when upgrading. (diff)
downloadgentoo-c4e6110acc43e8b8148cfeafa9c441ecb0c2a9e0.tar.gz
gentoo-c4e6110acc43e8b8148cfeafa9c441ecb0c2a9e0.tar.bz2
gentoo-c4e6110acc43e8b8148cfeafa9c441ecb0c2a9e0.zip
sys-freebsd: bump to 11.1
The following bugs have been fixed: - merged freebsd-libexec into freebsd-lib. #629166 - fix build failure with gcc-6. #629368
Diffstat (limited to 'sys-freebsd/freebsd-lib/files')
-rw-r--r--sys-freebsd/freebsd-lib/files/bootpd.confd7
-rw-r--r--sys-freebsd/freebsd-lib/files/bootpd.initd27
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-11.1-liblink.patch142
-rw-r--r--sys-freebsd/freebsd-lib/files/ftpd.pamd8
-rw-r--r--sys-freebsd/freebsd-lib/files/rquotad.xinetd11
-rw-r--r--sys-freebsd/freebsd-lib/files/rstatd.xinetd11
-rw-r--r--sys-freebsd/freebsd-lib/files/rusersd.xinetd11
-rw-r--r--sys-freebsd/freebsd-lib/files/sprayd.xinetd11
-rw-r--r--sys-freebsd/freebsd-lib/files/walld.xinetd11
9 files changed, 239 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-lib/files/bootpd.confd b/sys-freebsd/freebsd-lib/files/bootpd.confd
new file mode 100644
index 000000000000..6d238e4d4853
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/bootpd.confd
@@ -0,0 +1,7 @@
+# Configuration file for /etc/init.d/bootpd
+
+# Name of the configuration file for bootpd
+# bootptab_file="/etc/bootptab"
+
+# Options to pass to bootpd. See bootpd(8).
+# bootpd_opts=""
diff --git a/sys-freebsd/freebsd-lib/files/bootpd.initd b/sys-freebsd/freebsd-lib/files/bootpd.initd
new file mode 100644
index 000000000000..82288ebf19c3
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/bootpd.initd
@@ -0,0 +1,27 @@
+#!/sbin/openrc-run
+# Copyright 2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ local bootptab=${bootptab_file:-/etc/bootptab}
+
+ if ! [ -f "${bootptab}" ]; then
+ eerror "Unable to find the bootptab file: ${bootptab}"
+ eend 1
+ return 1
+ fi
+
+ ebegin "Starting BOOTP server"
+ start-stop-daemon --start --exec /usr/libexec/bootpd -- ${bootpd_opts} ${bootptab}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping BOOTP server"
+ start-stop-daemon --stop --exec /usr/libexec/bootpd
+ eend $?
+}
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-11.1-liblink.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.1-liblink.patch
new file mode 100644
index 000000000000..b1fe7035b120
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.1-liblink.patch
@@ -0,0 +1,142 @@
+diff --git a/lib/libmt/Makefile b/lib/libmt/Makefile
+index a6efe28..f60919a 100644
+--- a/lib/libmt/Makefile
++++ b/lib/libmt/Makefile
+@@ -6,6 +6,7 @@ SHLIBDIR?= /lib
+ SRCS= mtlib.c
+ INCS= mtlib.h
+
++CFLAGS+= -I${.CURDIR}
+ LIBADD= sbuf bsdxml
+
+ MAN= mt.3
+diff --git a/lib/libsysdecode/Makefile b/lib/libsysdecode/Makefile
+index ce89201..ba78ae4 100644
+--- a/lib/libsysdecode/Makefile
++++ b/lib/libsysdecode/Makefile
+@@ -9,7 +9,7 @@ SRCS= errno.c flags.c ioctl.c signal.c syscallnames.c utrace.c
+ INCS= sysdecode.h
+
+ CFLAGS+= -I${.OBJDIR}
+-CFLAGS+= -I${SRCTOP}/sys
++CFLAGS+= -I${SRCTOP}/sys -I${.CURDIR}
+ CFLAGS+= -I${SRCTOP}/libexec/rtld-elf
+
+ MAN= sysdecode.3 \
+
+diff --git a/lib/libdpv/Makefile b/lib/libdpv/Makefile
+index 280f7de..d0663b0 100644
+--- a/lib/libdpv/Makefile
++++ b/lib/libdpv/Makefile
+@@ -11,6 +11,7 @@ LIBADD= dialog figpar util ncursesw
+
+ SRCS= dialog_util.c dialogrc.c dprompt.c dpv.c status.c util.c
+
+-CFLAGS+= -I${.CURDIR}
++CFLAGS+= -I${.CURDIR} -I${.CURDIR}/../libfigpar
++LDFLAGS+= -L${.OBJDIR}/../libfigpar
+
+ .include <bsd.lib.mk>
+diff --git a/lib/libcasper/libcasper/Makefile b/lib/libcasper/libcasper/Makefile
+index 1064ada..32a2e66 100644
+--- a/lib/libcasper/libcasper/Makefile
++++ b/lib/libcasper/libcasper/Makefile
+@@ -18,6 +18,7 @@ INCS+= libcasper_service.h
+ LIBADD= nv
+
+ CFLAGS+=-I${.CURDIR}
++LDFLAGS+=-L${.OBJDIR}/../../libnv
+
+ MAN+= libcasper.3
+
+diff --git a/lib/libcasper/services/cap_dns/Makefile b/lib/libcasper/services/cap_dns/Makefile
+index bf6bed5..baeecbe 100644
+--- a/lib/libcasper/services/cap_dns/Makefile
++++ b/lib/libcasper/services/cap_dns/Makefile
+@@ -14,5 +14,6 @@ INCS= cap_dns.h
+ LIBADD= nv
+
+ CFLAGS+=-I${.CURDIR}
++LDFLAGS+=-L${.OBJDIR}/../../../libnv
+
+ .include <bsd.lib.mk>
+diff --git a/lib/libcasper/services/cap_grp/Makefile b/lib/libcasper/services/cap_grp/Makefile
+index 78a860a..dfb4911 100644
+--- a/lib/libcasper/services/cap_grp/Makefile
++++ b/lib/libcasper/services/cap_grp/Makefile
+@@ -14,5 +14,6 @@ INCS= cap_grp.h
+ LIBADD= nv
+
+ CFLAGS+=-I${.CURDIR}
++LDFLAGS+=-L${.OBJDIR}/../../../libnv
+
+ .include <bsd.lib.mk>
+diff --git a/lib/libcasper/services/cap_pwd/Makefile b/lib/libcasper/services/cap_pwd/Makefile
+index e4df38b..64d7709 100644
+--- a/lib/libcasper/services/cap_pwd/Makefile
++++ b/lib/libcasper/services/cap_pwd/Makefile
+@@ -14,5 +14,6 @@ INCS= cap_pwd.h
+ LIBADD= nv
+
+ CFLAGS+=-I${.CURDIR}
++LDFLAGS+=-L${.OBJDIR}/../../../libnv
+
+ .include <bsd.lib.mk>
+diff --git a/lib/libcasper/services/cap_random/Makefile b/lib/libcasper/services/cap_random/Makefile
+index d69c160..658be9c 100644
+--- a/lib/libcasper/services/cap_random/Makefile
++++ b/lib/libcasper/services/cap_random/Makefile
+@@ -14,5 +14,6 @@ INCS= cap_random.h
+ LIBADD= nv
+
+ CFLAGS+=-I${.CURDIR}
++LDFLAGS+=-L${.OBJDIR}/../../../libnv
+
+ .include <bsd.lib.mk>
+diff --git a/lib/libcasper/services/cap_sysctl/Makefile b/lib/libcasper/services/cap_sysctl/Makefile
+index 2471e65..b20a342 100644
+--- a/lib/libcasper/services/cap_sysctl/Makefile
++++ b/lib/libcasper/services/cap_sysctl/Makefile
+@@ -14,5 +14,6 @@ INCS= cap_sysctl.h
+ LIBADD= nv
+
+ CFLAGS+=-I${.CURDIR}
++LDFLAGS+=-L${.OBJDIR}/../../../libnv
+
+ .include <bsd.lib.mk>
+diff --git a/lib/libc/Makefile b/lib/libc/Makefile
+index 1cf73a7..f1c2bc8 100644
+--- a/lib/libc/Makefile
++++ b/lib/libc/Makefile
+@@ -51,6 +51,7 @@ CFLAGS+=${CANCELPOINTS_CFLAGS}
+ #
+ LDFLAGS+= -nodefaultlibs
+ LIBADD+= compiler_rt
++LDFLAGS+= -L${.OBJDIR}/../libcompiler_rt
+
+ .if ${MK_SSP} != "no"
+ LIBADD+= ssp_nonshared
+diff --git a/lib/libcompiler_rt/Makefile b/lib/libcompiler_rt/Makefile
+index 4da1166..b34297a 100644
+--- a/lib/libcompiler_rt/Makefile
++++ b/lib/libcompiler_rt/Makefile
+@@ -11,6 +11,7 @@ CFLAGS+= ${PICFLAG}
+ CFLAGS+= -fvisibility=hidden
+ CFLAGS+= -DVISIBILITY_HIDDEN
+ CFLAGS+= -I${SRCTOP}/contrib/libcxxrt
++LDFLAGS+= -L${.OBJDIR}/../libc
+
+ .if ${COMPILER_TYPE} == "clang"
+ CWARNFLAGS.gcc_personality_v0.c+= -Wno-typedef-redefinition
+diff --git a/lib/libcam/Makefile b/lib/libcam/Makefile
+index 310c9a2..86a5e8c 100644
+--- a/lib/libcam/Makefile
++++ b/lib/libcam/Makefile
+@@ -40,6 +40,7 @@ MLINKS+= cam.3 cam_open_device.3 \
+ ${SRCTOP}/sys/cam
+
+ CFLAGS+= -I${.CURDIR} -I${SRCTOP}/sys
++LDFLAGS+= -L${.OBJDIR}/../libsbuf
+
+ SHLIB_MAJOR= 7
+
diff --git a/sys-freebsd/freebsd-lib/files/ftpd.pamd b/sys-freebsd/freebsd-lib/files/ftpd.pamd
new file mode 100644
index 000000000000..8e9082373f8f
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/ftpd.pamd
@@ -0,0 +1,8 @@
+# PAM configuration for the "ftpd" service
+#
+
+auth include system-auth
+account include system-auth
+password include system-auth
+session include system-auth
+
diff --git a/sys-freebsd/freebsd-lib/files/rquotad.xinetd b/sys-freebsd/freebsd-lib/files/rquotad.xinetd
new file mode 100644
index 000000000000..876cd16c53c2
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/rquotad.xinetd
@@ -0,0 +1,11 @@
+service rquotad
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.rquotad
+ rpc_version = 1
+ disabled = yes
+}
diff --git a/sys-freebsd/freebsd-lib/files/rstatd.xinetd b/sys-freebsd/freebsd-lib/files/rstatd.xinetd
new file mode 100644
index 000000000000..ba1b819851eb
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/rstatd.xinetd
@@ -0,0 +1,11 @@
+service rstatd
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.rstatd
+ rpc_version = 1-3
+ disabled = yes
+}
diff --git a/sys-freebsd/freebsd-lib/files/rusersd.xinetd b/sys-freebsd/freebsd-lib/files/rusersd.xinetd
new file mode 100644
index 000000000000..5cbe091881e8
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/rusersd.xinetd
@@ -0,0 +1,11 @@
+service rusersd
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.rusersd
+ rpc_version = 1-2
+ disabled = yes
+}
diff --git a/sys-freebsd/freebsd-lib/files/sprayd.xinetd b/sys-freebsd/freebsd-lib/files/sprayd.xinetd
new file mode 100644
index 000000000000..7be55771ac22
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/sprayd.xinetd
@@ -0,0 +1,11 @@
+service sprayd
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.sprayd
+ rpc_version = 1
+ disabled = yes
+}
diff --git a/sys-freebsd/freebsd-lib/files/walld.xinetd b/sys-freebsd/freebsd-lib/files/walld.xinetd
new file mode 100644
index 000000000000..800b84fa21e6
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/walld.xinetd
@@ -0,0 +1,11 @@
+service walld
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.rwalld
+ rpc_version = 1
+ disabled = yes
+}