summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2016-10-11 21:37:39 +0900
committerAlexis Ballier <aballier@gentoo.org>2016-10-11 16:47:48 +0200
commite1bd456fcf9272cfdeaf542618c6b1f3ce3d1118 (patch)
tree6eb8e704f2281853b01e1abcd5770ad59d798e86 /sys-freebsd/freebsd-lib/files
parenteclass/freebsd.eclass: added FreeBSD 11.0 support. (diff)
downloadgentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.gz
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.bz2
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.zip
sys-freebsd: bump to 11.0
Diffstat (limited to 'sys-freebsd/freebsd-lib/files')
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-bsdxml2expat.patch39
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-liblink.patch62
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libproc-libcxx.patch13
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch22
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-workaround.patch12
5 files changed, 148 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-bsdxml2expat.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-bsdxml2expat.patch
new file mode 100644
index 000000000000..41a394b815a0
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-bsdxml2expat.patch
@@ -0,0 +1,39 @@
+diff --git a/lib/libgeom/geom_xml2tree.c b/lib/libgeom/geom_xml2tree.c
+index 9dedb8e..d96420c 100644
+--- a/lib/libgeom/geom_xml2tree.c
++++ b/lib/libgeom/geom_xml2tree.c
+@@ -43,7 +43,7 @@
+ #include <sys/sbuf.h>
+ #include <sys/sysctl.h>
+ #include <err.h>
+-#include <bsdxml.h>
++#include <expat.h>
+ #include <libgeom.h>
+
+ struct mystate {
+diff --git a/lib/libmt/mtlib.c b/lib/libmt/mtlib.c
+index d1fc0b1..89ac55e 100644
+--- a/lib/libmt/mtlib.c
++++ b/lib/libmt/mtlib.c
+@@ -48,7 +48,7 @@ __FBSDID("$FreeBSD: stable/10/lib/libmt/mtlib.c 280438 2015-03-24 14:36:10Z ken
+ #include <unistd.h>
+ #include <stdint.h>
+ #include <errno.h>
+-#include <bsdxml.h>
++#include <expat.h>
+ #include <mtlib.h>
+
+ /*
+diff --git a/lib/lib80211/lib80211_regdomain.c b/lib/lib80211/lib80211_regdomain.c
+index c500d3f..fe1d37e 100644
+--- a/lib/lib80211/lib80211_regdomain.c
++++ b/lib/lib80211/lib80211_regdomain.c
+@@ -40,7 +40,7 @@ static const char rcsid[] = "$FreeBSD: stable/11/lib/lib80211/lib80211_regdomain
+ #include <err.h>
+ #include <unistd.h>
+
+-#include <bsdxml.h>
++#include <expat.h>
+
+ #include "lib80211_regdomain.h"
+
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-liblink.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-liblink.patch
new file mode 100644
index 000000000000..da495e48ebf1
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-liblink.patch
@@ -0,0 +1,62 @@
+diff --git a/lib/libproc/Makefile b/lib/libproc/Makefile
+index 2dedf11..275f4c3 100644
+--- a/lib/libproc/Makefile
++++ b/lib/libproc/Makefile
+@@ -15,6 +15,7 @@ SRCS= proc_bkpt.c \
+ INCS= libproc.h
+
+ CFLAGS+= -I${.CURDIR}
++CFLAGS+= -I${.CURDIR}/../libelf
+
+ .if ${MK_CXX} == "no"
+ CFLAGS+= -DNO_CXA_DEMANGLE
+@@ -28,6 +29,9 @@ LIBADD+= elf rtld_db util
+
+ .if ${MK_CDDL} != "no"
+ LIBADD+= ctf
++LDADD+= -lelf
++LDFLAGS+= -L${.OBJDIR}/../libelf
++
+ IGNORE_PRAGMA= YES
+ CFLAGS+= -I${.CURDIR}/../../cddl/contrib/opensolaris/lib/libctf/common \
+ -I${.CURDIR}/../../sys/cddl/contrib/opensolaris/uts/common \
+diff --git a/lib/libprocstat/Makefile b/lib/libprocstat/Makefile
+index 1829883..d0065a3 100644
+--- a/lib/libprocstat/Makefile
++++ b/lib/libprocstat/Makefile
+@@ -17,6 +17,8 @@ VERSION_DEF= ${.CURDIR}/Versions.def
+ SYMBOL_MAPS= ${.CURDIR}/Symbol.map
+
+ INCS= libprocstat.h
++CFLAGS+= -I${.CURDIR}/../libelf
++LDFLAGS+= -L${.OBJDIR}/../libelf
+ CFLAGS+= -I. -I${.CURDIR} -D_KVM_VNODE
+ SHLIB_MAJOR= 1
+
+diff --git a/lib/librtld_db/Makefile b/lib/librtld_db/Makefile
+index 0a8ed95..11baf5b 100644
+--- a/lib/librtld_db/Makefile
++++ b/lib/librtld_db/Makefile
+@@ -11,6 +11,9 @@ SRCS= rtld_db.c
+ INCS= rtld_db.h
+
+ CFLAGS+= -I${.CURDIR}
++CFLAGS+= -I${.CURDIR}/../libelf
++LDADD+= -lutil -lproc
++LDFLAGS+= -L${.OBJDIR}/../libutil -L${.OBJDIR}/../libproc
+ # Avoid circular dependency, we only need the libproc.h header here.
+ CFLAGS+= -I${.CURDIR:H}/libproc
+
+diff --git a/lib/libtelnet/Makefile b/lib/libtelnet/Makefile
+index f84aee3..c36ade9 100644
+--- a/lib/libtelnet/Makefile
++++ b/lib/libtelnet/Makefile
+@@ -14,6 +14,8 @@ INTERNALLIB=
+ SRCS= genget.c getent.c misc.c
+ CFLAGS+= -I${TELNETDIR}
+
++CFLAGS+= -I${.CURDIR}/../libmp
++
+ WARNS?= 2
+
+ .if ${MK_OPENSSL} != "no"
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libproc-libcxx.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libproc-libcxx.patch
new file mode 100644
index 000000000000..013ad20619e5
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libproc-libcxx.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/libproc/Makefile b/lib/libproc/Makefile
+index e3b2578..acd76e8 100644
+--- a/lib/libproc/Makefile
++++ b/lib/libproc/Makefile
+@@ -18,7 +18,7 @@ CFLAGS+= -I${.CURDIR}
+
+ .if ${MK_CXX} == "no"
+ CFLAGS+= -DNO_CXA_DEMANGLE
+-.elif ${MK_LIBCPLUSPLUS} != "no"
++.elif ${COMPILER_TYPE} == "clang"
+ LIBADD+= cxxrt
+ .else
+ LIBADD+= supcplusplus
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch
new file mode 100644
index 000000000000..d90aa3163dae
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch
@@ -0,0 +1,22 @@
+diff --git a/lib/libsysdecode/Makefile b/lib/libsysdecode/Makefile
+index e3bfe00..51fc5f0 100644
+--- a/lib/libsysdecode/Makefile
++++ b/lib/libsysdecode/Makefile
+@@ -8,7 +8,7 @@ LIB= sysdecode
+ SRCS= errno.c ioctl.c syscallnames.c utrace.c
+ INCS= sysdecode.h
+
+-CFLAGS+= -I${.CURDIR}/../../sys
++CFLAGS+= -I${.CURDIR}/../../sys -I${.CURDIR}
+
+ MAN+= sysdecode.3 \
+ sysdecode_abi_to_freebsd_errno.3 \
+@@ -37,7 +37,7 @@ CFLAGS.gcc+= ${CFLAGS.gcc.${.IMPSRC}}
+
+ ioctl.c: mkioctls
+ env MACHINE=${MACHINE} CPP="${CPP}" \
+- /bin/sh ${.CURDIR}/mkioctls ${DESTDIR}${INCLUDEDIR} > ${.TARGET}
++ /bin/sh ${.CURDIR}/mkioctls ${.CURDIR}/../../include > ${.TARGET}
+
+ beforedepend: ioctl.c
+
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-workaround.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-workaround.patch
new file mode 100644
index 000000000000..05f817eeb032
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-workaround.patch
@@ -0,0 +1,12 @@
+diff --git a/lib/libdevdctl/event.cc b/lib/libdevdctl/event.cc
+index a8cb447..d56df2e 100644
+--- a/lib/libdevdctl/event.cc
++++ b/lib/libdevdctl/event.cc
+@@ -50,6 +50,7 @@
+ #include <syslog.h>
+ #include <unistd.h>
+
++#include <cstdio>
+ #include <cstdarg>
+ #include <cstring>
+ #include <iostream>