summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-13 17:14:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-13 17:15:13 +0200
commit22d3fbf7721ec935ea503c9eb10c775a22f96e84 (patch)
tree6618ae675abbb4c030ed9951c99694e0d0605856 /sys-fs
parentsys-apps/baselayout-prefix: prefix-stack: ROOTPATH needs EPREFIX before BROOT (diff)
downloadgentoo-22d3fbf7721ec935ea503c9eb10c775a22f96e84.tar.gz
gentoo-22d3fbf7721ec935ea503c9eb10c775a22f96e84.tar.bz2
gentoo-22d3fbf7721ec935ea503c9eb10c775a22f96e84.zip
sys-fs/cryptsetup: Respect libressl USE flag
Closes: https://bugs.gentoo.org/678200 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild11
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild11
2 files changed, 18 insertions, 4 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild b/sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild
index a4271834ba82..095fb0b3fc6a 100644
--- a/sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild
@@ -13,7 +13,9 @@ LICENSE="GPL-2+"
SLOT="0/12" # libcryptsetup.so version
[[ ${PV} != *_rc* ]] && \
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-CRYPTO_BACKENDS="gcrypt kernel nettle +openssl"
+# cryptsetup does _not_ have a libressl backend. We only have this for REQUIRED_USE
+# and change "libressl" to "openssl" in our econf call.
+CRYPTO_BACKENDS="gcrypt kernel libressl nettle +openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
IUSE="${CRYPTO_BACKENDS} +argon2 libressl +luks1_default nls pwquality reencrypt static static-libs +udev urandom"
@@ -79,6 +81,11 @@ src_configure() {
ewarn "userspace crypto libraries."
fi
+ local x cryptobackend
+ for x in ${CRYPTO_BACKENDS//+/} ; do
+ use ${x} && cryptobackend="${x/libressl/openssl}"
+ done
+
local myeconfargs=(
--disable-internal-argon2
--enable-shared
@@ -86,7 +93,7 @@ src_configure() {
# for later use
--with-default-luks-format=LUKS$(usex luks1_default 1 2)
--with-tmpfilesdir="${EPREFIX%/}/usr/lib/tmpfiles.d"
- --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
+ --with-crypto_backend=${cryptobackend}
$(use_enable argon2 libargon2)
$(use_enable nls)
$(use_enable pwquality)
diff --git a/sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild b/sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild
index 457a33aa1fbe..e0142bdc5218 100644
--- a/sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild
@@ -13,7 +13,9 @@ LICENSE="GPL-2+"
SLOT="0/12" # libcryptsetup.so version
[[ ${PV} != *_rc* ]] && \
KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-CRYPTO_BACKENDS="gcrypt kernel nettle +openssl"
+# cryptsetup does _not_ have a libressl backend. We only have this for REQUIRED_USE
+# and change "libressl" to "openssl" in our econf call.
+CRYPTO_BACKENDS="gcrypt kernel libressl nettle +openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
IUSE="${CRYPTO_BACKENDS} +argon2 libressl +luks1_default nls pwquality reencrypt static static-libs +udev urandom"
@@ -79,6 +81,11 @@ src_configure() {
ewarn "userspace crypto libraries."
fi
+ local x cryptobackend
+ for x in ${CRYPTO_BACKENDS//+/} ; do
+ use ${x} && cryptobackend="${x/libressl/openssl}"
+ done
+
local myeconfargs=(
--disable-internal-argon2
--enable-shared
@@ -86,7 +93,7 @@ src_configure() {
# for later use
--with-default-luks-format=LUKS$(usex luks1_default 1 2)
--with-tmpfilesdir="${EPREFIX%/}/usr/lib/tmpfiles.d"
- --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
+ --with-crypto_backend=${cryptobackend}
$(use_enable argon2 libargon2)
$(use_enable nls)
$(use_enable pwquality)