summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:51:32 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:51:32 +0200
commit3bedcb4a916e0ff46ad3cd00c9df5f7bbfd1a7be (patch)
tree25f155e2be9895de35424f83660eaccf90636535 /sys-fs
parentsys-fs/reiserfsprogs: port to EAPI 7 (diff)
downloadgentoo-3bedcb4a916e0ff46ad3cd00c9df5f7bbfd1a7be.tar.gz
gentoo-3bedcb4a916e0ff46ad3cd00c9df5f7bbfd1a7be.tar.bz2
gentoo-3bedcb4a916e0ff46ad3cd00c9df5f7bbfd1a7be.zip
sys-fs/static-dev: port to EAPI 7
* Port to EAPI 7 * Move sys-apps/makedev to RDEPEND as it's only needed at runtime and in pkg_postinst Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/static-dev/static-dev-0.1-r1.ebuild (renamed from sys-fs/static-dev/static-dev-0.1.ebuild)19
1 files changed, 8 insertions, 11 deletions
diff --git a/sys-fs/static-dev/static-dev-0.1.ebuild b/sys-fs/static-dev/static-dev-0.1-r1.ebuild
index c1a62712d168..42c60e497de4 100644
--- a/sys-fs/static-dev/static-dev-0.1.ebuild
+++ b/sys-fs/static-dev/static-dev-0.1-r1.ebuild
@@ -1,28 +1,24 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
DESCRIPTION="A skeleton, statically managed /dev"
HOMEPAGE="https://bugs.gentoo.org/107875"
-SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE=""
RDEPEND="sys-apps/makedev"
-DEPEND="${RDEPEND}"
-
-abort() {
- echo
- eerror "We have detected that you currently use udev or devfs or devtmpfs"
- eerror "and this ebuild cannot install to the same mount-point."
- die "Cannot install on udev/devfs tmpfs."
-}
pkg_pretend() {
+ abort() {
+ eerror "We have detected that you currently use udev or devfs or devtmpfs"
+ eerror "and this ebuild cannot install to the same mount-point."
+ die "Cannot install on udev/devfs tmpfs."
+ }
+
if [[ ${MERGE_TYPE} == "buildonly" ]] ; then
# User is just compiling which is fine -- all our checks are merge-time.
return
@@ -32,6 +28,7 @@ pkg_pretend() {
if [[ -d ${ROOT}/dev/.udev || -c ${ROOT}/dev/.devfs ]] ; then
abort
fi
+
# We also want to not clobber newer devtmpfs setups.
if [[ ${ROOT} == "/" ]] && \
! awk '$2 == "/dev" && $3 == "devtmpfs" { exit 1 }' /proc/mounts ; then